Ticket #4849 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Browse and chat don't share

Reported by: kimquirk Owned by: mstone
Priority: blocker Milestone: Update.1
Component: security Version:
Keywords: rainbow-integration Cc:
Action Needed: Verified: no
Deployments affected: Blocked By:
Blocking:

Description

Build 262, q2d04

I have two laptops with this build; connected to the internet through a local AP; and they see many other laptops (jabber.laptop.org).

I tried to set up a chat session and I tried to share a browse session; and in both cases nothing shows up in the neighborhood mesh view. Both the chat and browse logs say 'Error Root: error reading private key.'

This may be the same issue as #4847.

I'm putting it in security for now... please move as appropriate.

Change History

Changed 6 years ago by mstone

  • keywords rainbow-integration added

Adding the rainbow-integration tag until we have a real diagnosis.

Changed 6 years ago by marco

Works for me in 267.

Changed 6 years ago by mstone

The deal is that activity isolation is currently preventing activities from talking to Telepathy's connection managers because I didn't realize that Telepathy's connection managers perform uid checks on processes attempting to connected to unix sockets provided by Telepathy.

We discussed a dirty hack and an API change for resolving this. We're going to proceed with the dirty hack for Update.1 because we need to maintain as much API compatibility as we can.

The hack consists of turning off the access check in the OLPC fork of telepathy.

Changed 6 years ago by mstone

Reported fixed in joyride-281 by Robot101.

Changed 6 years ago by mstone

  • status changed from new to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.