Opened 7 years ago

Closed 7 years ago

#4907 closed defect (fixed)

PS doesn't try to reconnect Gabble if initial connect attempt failed

Reported by: gdesmott Owned by: robot101
Priority: normal Milestone: Update.1
Component: presence-service Version: Development source as of this date
Keywords: review+ Update.1? Cc: smcv, morgs
Blocked By: Blocking:
Deployments affected: Action Needed:
Verified: no

Description

To reproduce:

  • edit your ~/.sugar/default/config and set an unexisting jabber server
  • Launch sugar. Gabble can't connect to its server
  • After 5 seconds, the timer is activated but start() won't try to reconnect because self._conn is not None

Attachments (1)

ps-reconnect.patch (976 bytes) - added by gdesmott 7 years ago.

Download all attachments as: .zip

Change History (9)

Changed 7 years ago by gdesmott

comment:1 Changed 7 years ago by smcv

11:41 < smcv> cassidy: change the second part to "if not dbus_name and 
              self._conn is not None", otherwise +1
11:42 < smcv> cassidy: (with dbus_name we're testing for e.g. ":1.9" vs "", so 
              a truth test is what we want - but when comparing to None, always 
              use "is [not] None" because it's more efficient and is what you 
              actually mean)

However, the 5 second retry frequency is likely to flood the network, so this bug shouldn't be fixed until #2522 also is (fixing both of them in the same PS release would be ideal).

comment:2 Changed 7 years ago by gdesmott

  • Keywords review+ added

comment:3 Changed 7 years ago by gdesmott

  • Component changed from telepathy-gabble to presence-service
  • Owner changed from smcv to ApprovalForUpdate

Now #2522 was fixed and approved for Update.1, what about this fix?

comment:4 Changed 7 years ago by robot101

  • Keywords Update.1? added
  • Milestone changed from Never Assigned to Update.1

comment:5 Changed 7 years ago by jg

  • Owner changed from ApprovalForUpdate to gdesmott

Is this in Joyride? If not, please put it there and test it for update.1.

Once tested in Joyride, reassign to Approval for update.....

comment:6 Changed 7 years ago by robot101

  • Owner changed from gdesmott to ApprovalForUpdate

It's in Joyride since 0.27.20071114git128c59c612 and has been tested. That one release had four fixes in, for #4936, #4896, #2522 and this bug. It just needs tagging for Update.1.

comment:7 Changed 7 years ago by jg

  • Owner changed from ApprovalForUpdate to robot101

this is believed included in update.1 build 637, please verify that it is fixed and then close this bug.

comment:8 Changed 7 years ago by gdesmott

  • Resolution set to fixed
  • Status changed from new to closed

Seems ok in update1-639

Note: See TracTickets for help on using tickets.