Ticket #5007 (closed defect: invalid)

Opened 7 years ago

Last modified 7 years ago

Mesh repeats multicast too much.

Reported by: dwmw2 Owned by: mbletsas
Priority: normal Milestone: Future Release
Component: wireless Version:
Keywords: Cc:
Action Needed: Verified: no
Deployments affected: Blocked By:
Blocking:

Description

This is a _single_ ping packet and its echoes, on the mesh...

15:50:38.975326 2.0 Mb/s 2412 MHz (0x0480) 225dB signal [0x0000000e] 0us RA:33:33:00:00:01:14 TA:00:17:c4:02:2d:b9 DA:33:33:00:00:01:14 SA:00:17:c4:02:2d:b9 LLC, dsap Null (0x00) Individual, ssap Null (0x00) Command, ctrl 0xaaaa: Information, send seq 85, rcv seq 85, Flags [Command], length 123
15:50:38.978748 2.0 Mb/s 2412 MHz (0x0480) 212dB signal [0x0000000e] 0us RA:33:33:00:00:01:14 TA:00:17:c4:05:2a:90 DA:33:33:00:00:01:14 SA:00:17:c4:02:2d:b9 LLC, dsap Null (0x00) Individual, ssap Null (0x00) Command, ctrl 0xaaaa: Information, send seq 85, rcv seq 85, Flags [Command], length 123
15:50:38.980325 2.0 Mb/s 2412 MHz (0x0480) 208dB signal [0x0000000e] 0us RA:33:33:00:00:01:14 TA:00:17:c4:05:2a:b8 DA:33:33:00:00:01:14 SA:00:17:c4:02:2d:b9 LLC, dsap Null (0x00) Individual, ssap Null (0x00) Command, ctrl 0xaaaa: Information, send seq 85, rcv seq 85, Flags [Command], length 123
15:50:38.982140 2.0 Mb/s 2412 MHz (0x0480) 205dB signal [0x0000000e] 0us RA:33:33:00:00:01:14 TA:00:17:c4:05:25:09 DA:33:33:00:00:01:14 SA:00:17:c4:02:2d:b9 LLC, dsap Null (0x00) Individual, ssap Null (0x00) Command, ctrl 0xaaaa: Information, send seq 85, rcv seq 85, Flags [Command], length 123
15:50:38.982928 2.0 Mb/s 2412 MHz (0x0480) 208dB signal [0x0000000e] 0us RA:33:33:00:00:01:14 TA:00:17:c4:03:36:0f DA:33:33:00:00:01:14 SA:00:17:c4:02:2d:b9 LLC, dsap Null (0x00) Individual, ssap Null (0x00) Command, ctrl 0xaaaa: Information, send seq 85, rcv seq 85, Flags [Command], length 123
15:50:38.983718 2.0 Mb/s 2412 MHz (0x0480) 197dB signal [0x0000000e] 0us RA:33:33:00:00:01:14 TA:00:17:c4:05:23:92 DA:33:33:00:00:01:14 SA:00:17:c4:02:2d:b9 LLC, dsap Null (0x00) Individual, ssap Null (0x00) Command, ctrl 0xaaaa: Information, send seq 85, rcv seq 85, Flags [Command], length 123
15:50:39.009270 2.0 Mb/s 2412 MHz (0x0480) 225dB signal [0x0000000e] 0us RA:33:33:00:00:01:14 TA:00:17:c4:05:2c:e1 DA:33:33:00:00:01:14 SA:00:17:c4:02:2d:b9 LLC, dsap Null (0x00) Individual, ssap Null (0x00) Command, ctrl 0xaaaa: Information, send seq 85, rcv seq 85, Flags [Command], length 123
15:50:39.012918 2.0 Mb/s 2412 MHz (0x0480) 201dB signal [0x0000000e] 0us RA:33:33:00:00:01:14 TA:00:17:c4:05:23:7f DA:33:33:00:00:01:14 SA:00:17:c4:02:2d:b9 LLC, dsap Null (0x00) Individual, ssap Null (0x00) Command, ctrl 0xaaaa: Information, send seq 85, rcv seq 85, Flags [Command], length 123
15:50:39.024262 2.0 Mb/s 2412 MHz (0x0480) 199dB signal [0x0000000e] 0us RA:33:33:00:00:01:14 TA:00:17:c4:05:27:9b DA:33:33:00:00:01:14 SA:00:17:c4:02:2d:b9 LLC, dsap Null (0x00) Individual, ssap Null (0x00) Command, ctrl 0xaaaa: Information, send seq 85, rcv seq 85, Flags [Command], length 123
15:50:39.033113 2.0 Mb/s 2412 MHz (0x0480) 195dB signal [0x0000000e] 0us RA:33:33:00:00:01:14 TA:00:50:43:28:0b:12 DA:33:33:00:00:01:14 SA:00:17:c4:02:2d:b9 LLC, dsap Null (0x00) Individual, ssap Null (0x00) Command, ctrl 0xaaaa: Information, send seq 85, rcv seq 85, Flags [Command], length 123
15:50:39.033925 2.0 Mb/s 2412 MHz (0x0480) 208dB signal [0x0000000e] 0us RA:33:33:00:00:01:14 TA:00:17:c4:00:00:01 DA:33:33:00:00:01:14 SA:00:17:c4:02:2d:b9 LLC, dsap Null (0x00) Individual, ssap Null (0x00) Command, ctrl 0xaaaa: Information, send seq 85, rcv seq 85, Flags [Command], length 123
15:50:39.048722 2.0 Mb/s 2412 MHz (0x0480) 205dB signal [0x0000000e] 0us RA:33:33:00:00:01:14 TA:00:17:c4:05:27:34 DA:33:33:00:00:01:14 SA:00:17:c4:02:2d:b9 LLC, dsap Null (0x00) Individual, ssap Null (0x00) Command, ctrl 0xaaaa: Information, send seq 85, rcv seq 85, Flags [Command], length 123

Change History

Changed 7 years ago by mbletsas

Pretty normal for such a dense mesh.

You should be getting one echo of the frame from every direct neighbor of its source.

M.

Changed 7 years ago by jg

  • milestone changed from Never Assigned to Future Release

Michail, so are you going to close this as invalid?

Changed 7 years ago by mbletsas

  • status changed from new to closed
  • resolution set to invalid

Changed 7 years ago by dwmw2

I wonder if this is the root cause of #5553?

Changed 7 years ago by mbletsas

Dave,

A variety of issues contribute to the 1cc mess (caused by the mesh traffic ;-)

* Too many radios (mostly a feature manifesting as a bug ;-)

* Excessive probe responses (dealt with in .p47 and .p48)

* mDNS traffic transmitted at basic rates (easily tunable) mesh_set_bcastr rate

Sets the rate index for mesh broadcast and muticast packets. Rates are expressed in expressed in 2 * Mb/s, ie 11Mb/s is 22, 5.5Mb/s is 11, etc.

iwpriv ethX mesh_set_bcastr rate

I think we should close this for now.

M.

Note: See TracTickets for help on using tickets.