Opened 7 years ago

Closed 7 years ago

#5127 closed defect (fixed)

Crash running activities while indexing usb

Reported by: marco Owned by: tomeu
Priority: blocker Milestone: Update.1
Component: sugar-datastore Version:
Keywords: relnote, review+ Cc: marco, tomeu
Blocked By: Blocking:
Deployments affected: Action Needed:
Verified: no

Description

To reproduce:

1 Take an usb with a lot of files on it and no .olpc.store.
2 Start sugar, insert the usb stick, launch an activity.

The sugar-datastore process is gone and activities does not start anymore.

From gdb it looks like it's crashing in FlintTable_base::block_free_at_start.

Attachments (1)

index_on_idle.patch (8.0 KB) - added by tomeu 7 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 7 years ago by jg

  • Milestone changed from Never Assigned to Update.1

comment:2 Changed 7 years ago by kimquirk

  • Keywords relnote added

Changed 7 years ago by tomeu

comment:3 Changed 7 years ago by tomeu

  • Cc marco added
  • Keywords review? added

Marco, can you review, please?

comment:4 follow-up: Changed 7 years ago by marco

  • Keywords review+ added; review? removed

Looks good, do we actually need to flush for every file?

comment:5 in reply to: ↑ 4 Changed 7 years ago by tomeu

Replying to marco:

Looks good, do we actually need to flush for every file?

We should do a flush for every change we do, so we do a real flush every X changes or X seconds after last change.

But in that case no flush should be done because an implicit flush happens inside create(). Will take that flush out and push to HEAD for testing in joyride.

comment:6 Changed 7 years ago by tomeu

  • Owner changed from tomeu to marco

Pushed, can you do an rpm?

comment:7 Changed 7 years ago by tomeu

  • Cc tomeu added

comment:8 Changed 7 years ago by marco

  • Owner changed from marco to tomeu

It will be in the next joyride.

comment:9 Changed 7 years ago by marco

  • Owner changed from tomeu to ApprovalForUpdate

Seem to work well in joyride and I could not reproduce the crash with it.

comment:10 Changed 7 years ago by jg

  • Owner changed from ApprovalForUpdate to dgilmore

Approved for Update.1

comment:11 Changed 7 years ago by marco

  • Owner changed from dgilmore to tomeu

The ticket to get this in the build is now #5350. Reassigning to Tomeu for testing when it lands in Update.1.

comment:12 Changed 7 years ago by marco

  • Resolution set to fixed
  • Status changed from new to closed

Verified fixed in 657

Note: See TracTickets for help on using tickets.