Ticket #5156 (closed defect: fixed)

Opened 7 years ago

Last modified 6 years ago

Browse hangs on google calendar

Reported by: kimquirk Owned by: erikos
Priority: high Milestone: 8.2.0 (was Update.2)
Component: browse-activity Version:
Keywords: Browse-94:+ Cc: tomeu, jg, walter, jaz@…
Action Needed: finalize Verified: no
Deployments affected: Blocked By:
Blocking: #7421

Description

Build 642, q2d04l

Open browse, goto gmail.google.com; login; then click on calendar in the upper left.

My browser window continues to show the word 'loading' and doesn't ever load.

If you go to calendar.google.com; and log in, the calendar comes up. So it must be related to opening a second window.

Attachments

gmail_flash.log (3.9 kB) - added by erikos 7 years ago.
the browse log when accessing gmail/calendar

Change History

Changed 7 years ago by tomeu

  • cc tomeu added

Changed 7 years ago by erikos

the browse log when accessing gmail/calendar

Changed 7 years ago by erikos

  • keywords Update.1 added

can definitely reproduce this issue, same behavior occur when I click on the other links like picture etc. Sometimes it just hangs there with the "Loading..." message and does not go any further but most of the times I get the following message after a moment:

This seems to be taking longer than usual.<br><br>If you are using a slow Internet connection, you can wait a bit longer for this page to finish loading, or just use <a href="http://mail.google.com/mail/?ui=html">basic HTML view</a> for now.<br><br>If
you are using your normal Internet connection and you usually get past
this loading step without any problems, please refresh this page in
your browser. If you continue to have trouble loading your account,
please <a style="color: rgb(0, 0, 204);" href="http://mail.google.com/support/bin/static.py?page=troubleshooter.cs&amp;problem=bugflow&amp;selected=sign_load2&amp;hl=en">visit the help center</a> for troubleshooting information.

When i then use the link "basic HTML view" i will be back on the page i left.

a) I can open it on mozilla3 fine - the new page gets opened in a separate tab though. b) using the same url than the one that is opened in mozilla3 I can open the desired page on the xo as well c) I removed gnash and installed flash - same behavior - does never make it to the page d) i tested the opening of another window from a link, and on the xo this is opened in the same window as expected

<html><a href="http://www.gnome.org" target='blank'> hello </a> </html>

More tests to come.

Maybe this is even ship.2

Changed 7 years ago by erikos

  • keywords Update.1? added; Update.1 removed

Changed 7 years ago by jg

  • keywords Update.1? removed
  • milestone changed from Never Assigned to Update.1

Changed 7 years ago by marco

We get the same result if we remove target=_blank from the link in the firefox DOM Inspector. Not sure what the web site is doing there.

Changed 7 years ago by marco

Note that the Docs link works fine.

Changed 7 years ago by marco

Not much we can do about this without google help, I fear.

Changed 7 years ago by marco

  • milestone changed from Update.1 to Retriage, Please!

Changed 7 years ago by kimquirk

  • cc jg, walter added

Jim, Walter, How important is it to work with google calendar? This needs to be triaged.

Changed 7 years ago by jg

Does it work with the new browser in joyride? Sounding grim from Marco's comments, though.... I'd say calendar is way less important than mail, particularly since it seems there are other ways to get calendar going...

Changed 7 years ago by marco

I haven't tested but I think it's unlikely that it will work. It doesn't even work in stable firefox (once you modify the DOM to open in the same window).

Changed 7 years ago by jg

  • milestone changed from Retriage, Please! to Update.2

OK, time to file an upstream bug in Mozilla's bugzilla, me thinks...

Changed 7 years ago by jg

oh, Walter, do we have a google calendar contact we can contact?

Changed 7 years ago by walter

Mike Jazayeri <jaz@…>

Changed 7 years ago by jg

  • cc jaz@… added

Changed 6 years ago by cscott

  • next_action set to never set

Same bug still present in joyride-2097; opening 'calendar.google.com' directly works, as reported.

It seems that whatever magic google is doing to get the link to open in its own tab is failing on our browser.

Changed 6 years ago by cscott

  • blocking 7421 added

Changed 6 years ago by cscott

Maybe related to #6825?

Changed 6 years ago by tomeu

Sounds more like #7023 to me, that same workaround works well in this case.

May be interesting to run mozilla with a higher level of logging and check all the javascript warnings.

Changed 6 years ago by marco

  • next_action changed from never set to test in build

I'd expect this to be fixed by the new popups logic.

Changed 6 years ago by erikos

  • keywords Browse-94:+ added
  • next_action changed from test in build to finalize

Works great with the new popup logic. The calendar gets opened in the same window (firefox does open it in a separate window).

Changed 6 years ago by erikos

|TestCase| Login to your google account. Use the 'Calendar' link at the top left to open the calendar. It opens in the same window and you can use it as expected.

Changed 6 years ago by gregorio

  • status changed from new to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.