Ticket #5203 (closed defect: invalid)

Opened 7 years ago

Last modified 7 years ago

WLAN doesn't come up properly from boot

Reported by: kimquirk Owned by: dwmw2
Priority: high Milestone: Update.1
Component: wireless Version:
Keywords: Cc: michailis, dwmw2
Action Needed: Verified: no
Deployments affected: Blocked By:
Blocking:

Description

643, ship.2 code

On my set of 8 laptops running this code, when I reboot them invariably 1-3 laptops will come up with no WLAN. If you watch the sugar home screen you can see the grey circle appear for a little while and then it just disappears by the time the rest of the boot is finished.

I will try to get a var/log/message file from the next time.

Change History

  Changed 7 years ago by jg

  • cc michailis added

  Changed 7 years ago by jg

  • milestone changed from Never Assigned to Update.1

follow-up: ↓ 4   Changed 7 years ago by dwmw2

We can't do anything with this without more details. Did the wireless device even show up on the USB bus? Did it appear but fail to initialise? Did it appear, initialise, then go wrong?

There have been changes in recent firmware surrounding the initial firmware loading. Those _shouldn't_ have broken anything, although they were a very bad idea at this point in the proceedings. Afaict it was just done to optimise away a 200ms delay, which is _really_ not something we should have been doing this week.

in reply to: ↑ 3   Changed 7 years ago by jcardona

Replying to dwmw2:

There have been changes in recent firmware surrounding the initial firmware loading. Those _shouldn't_ have broken anything, although they were a very bad idea at this point in the proceedings. Afaict it was just done to optimise away a 200ms delay, which is _really_ not something we should have been doing this week.

You are probably referring to the firmware_ready event, used to report that the firmware is ready for commands. This was requested by Mitch Bradley, after discovering the root cause of #4637.

This event is only on firmware version 5.110.21.pX, which is not included in build 643, ship.2

  Changed 7 years ago by dwmw2

  • cc dwmw2 added
  • status changed from new to closed
  • resolution set to invalid

Closing invalid. Without even any indication of whether the devices appeared on the USB bus, this bug report is totally useless.

Note: See TracTickets for help on using tickets.