Ticket #5258 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

WPA does not work at all.

Reported by: ffm Owned by: testing
Priority: blocker Milestone: Update.1
Component: network manager Version: Development build as of this date
Keywords: Cc: bemasc, yani, carrano, tomeu, holt, rwh
Action Needed: Verified: no
Deployments affected: Blocked By:
Blocking:

Description

Steps to reproduce: 1. Boot laptop 2. Try to connect to a WPA network. 3. Press OK.

then, nothing happens. Dialog does not even disappear

Attachments

messages.wpa (51.1 kB) - added by rwh 6 years ago.
shell.log.wpa (10.7 kB) - added by rwh 6 years ago.
messages (106.0 kB) - added by bemasc 6 years ago.
/var/log/messages showing WPA failure from Sugar on joyride-1403
shell.log (9.5 kB) - added by bemasc 6 years ago.
shell.log showing WPA connect failure in Sugar on joyride-1403
nm.log (49.6 kB) - added by bemasc 6 years ago.
NetworkManager --no-daemon log showing failure on 1403.

Change History

Changed 6 years ago by ffm

Oh, and If I press it enough times, sugar freezes. (also occurs in ship.2)

Changed 6 years ago by ffm

It should be noted that after attempting to conect to a WPA network, all attempts to connect to other networks fail, even if the other networks use WEP or no encryption.

Changed 6 years ago by ffm

  • status changed from new to closed
  • resolution set to fixed

Oops, seems to work in latest build.

Changed 6 years ago by chiaying.lin

I tried it with image 649. It seems not work.

Changed 6 years ago by cscott

  • status changed from closed to reopened
  • resolution deleted

Reports are that this is still broken in ship.2. Does this work in joyride?

Changed 6 years ago by cscott

  • owner changed from dcbw to bemasc
  • status changed from reopened to new

Changed 6 years ago by cscott

marcopg: c_scott: I don't have WPA networks to test with here, but if bemasc does some testing I can help tracking it down

Changed 6 years ago by bemasc

  • owner changed from bemasc to marco

Under Joyride-1403, connection to my WPA access point fails. The access point is a Linksys WRT54G running WPA PSK-TKIP (also known as WPA-1). The name of the network is "bluesteel"; I recommend searching through the logs for that string.

Changed 6 years ago by bemasc

  • cc bemasc added

Changed 6 years ago by bernie

  • cc yani, carrano, tomeu added

Ricardo points out this workaround:

http://wiki.laptop.org/go/OLPC_Ship.2_Software_Release_Notes#Network_Connectivity

Tomeu seems to have recently worked on keydialog.py lately, which is the module that is said to contain the bug.

Could any of you please look into it? At tonight's IRC meeting this bug was suggested as critical for Update.1.

Changed 6 years ago by HoboPrimate

Could this be simillar to #5044 (with WPA-PSK)?

Changed 6 years ago by bemasc

To be clear, the symptoms are very slightly differentfrom #5044. In #5044: "After entering the password pressing Enter or choosing OK doesn't dismiss the dialog."

In this case, pressing OK does dismiss the dialog. The WPA AP's circle blinks for many seconds, and eventually fails. Normally, after failure, the dialog reappears again.

Changed 6 years ago by holt

  • cc holt added

Changed 6 years ago by marco

This is not #5044, looking at shell.log (#5044 is fixed in joyride).

Changed 6 years ago by rwh

Changed 6 years ago by rwh

Changed 6 years ago by rwh

  • cc rwh added

WPA works for me in joyride 1371 with a D-Link DIR-635 (FW 1.09w). See logs for details.

I removed ~/.sugar/default/nm and /etc/wpa_supplicant/wpa_supplicant.conf and rebooted before taking these logs.

Changed 6 years ago by bemasc

/var/log/messages showing WPA failure from Sugar on joyride-1403

Changed 6 years ago by bemasc

shell.log showing WPA connect failure in Sugar on joyride-1403

Changed 6 years ago by bemasc

NetworkManager --no-daemon log showing failure on 1403.

Changed 6 years ago by bemasc

Added new failure logs.

Changed 6 years ago by jg

  • milestone changed from Never Assigned to Update.1

Changed 6 years ago by carrano

I updated the information on the wiki regarding a workaround to connect to an encrypted AP, if the user interface fails.

Please check: http://wiki.laptop.org/go/WPA_Manual_Setting

Changed 6 years ago by dcbw

As a data point, build 650 works just fine for me with a B2-1 and a Linksys WRT54GC which is based on the broadcom chipset. This is, of course, after commenting out the sigchld handler from /usr/bin/sugar-shell

Changed 6 years ago by marco

bemasc, ffm, can you please give this another try on 666?

Changed 6 years ago by ffm

works for me on latest joyride.

Changed 6 years ago by MrDomino

It appears as though the most recent update.1 build (667) broke WPA entirely---I can't connect through either the neighborhood view or the WPA.sh shell script.

Changed 6 years ago by ffm

Still works flawlessly in joyride and 653.

Changed 6 years ago by bemasc

Still broken in 671.

Changed 6 years ago by kimquirk

  • owner changed from marco to testing

Changed 6 years ago by jg

  • status changed from new to closed
  • resolution set to fixed

Tested in current joyride and update.1..

Note: See TracTickets for help on using tickets.