Ticket #543 (closed defect: fixed)

Opened 8 years ago

Last modified 7 years ago

Critical low battery can't be charged with ac power.

Reported by: arvinliu Owned by: rsmith
Priority: high Milestone: Trial-1
Component: embedded controller Version:
Keywords: relnote, battery Cc: wmb@…, wad, mlj, smithbone
Action Needed: Verified: yes
Deployments affected: Blocked By:
Blocking:

Description

Critical low battery can't be charged with ac power.I had be try five time and fail five battery. Test procedure: 1.CL1 boot to X-windows system without AC power. 2.Idle and into Critical low battery, system should shundown 3.Proceed to discharge electricity.Allow battery capacity lower. Example:proceed to idle without ac power. 4.Plug AC power,Battery LED can't action.Battery can't be charged.

Change History

  Changed 8 years ago by jg

Please tell us the version of the BIOS you are running: that will tell you what version of the EC code is running in bug reports.

in reply to: ↑ description ; follow-up: ↓ 3   Changed 8 years ago by ted.juan

No matter is Q2A42 or Q2A51 BIOS all will happen the serious prolem.

The root cause is the EC won't do the precharge now.

EC can't recognize the correct Battery type since there is no enough voltage.

Then it won't do the charge because there is risk to charge the unknown battery.

The new EC version PQ2A62 will fixed the problem.

It will precharge a short time,then try to read battery type.

If it still can't recognize the battery, just stop to chrage.

in reply to: ↑ 2 ; follow-up: ↓ 4   Changed 8 years ago by Nat

I just upgraded to the latest firmware, after a while my battery indicator flashes red every 4 second. Rebooting seems to fix the problem but only for a certain moment. Any ideas ?

in reply to: ↑ 3 ; follow-up: ↓ 5   Changed 8 years ago by Nat

It appears that the battery is not charging at all with A62, on 2 laptops here the battery doesn't charge, either no light or the flashing red light.

in reply to: ↑ 4   Changed 8 years ago by ted.juan

Replying to Nat:

It appears that the battery is not charging at all with A62, on 2 laptops here the battery doesn't charge, either no light or the flashing red light.

When you updated the different EC code, the EC need to be reset again.

Since the EC RAM data have been changed, sometimes it will be abnormal.

I suggest Flash utility to do the EC reset after flashing EC code.

  Changed 8 years ago by jg

  • cc wmb@… added
  • owner changed from ted.juan to rsmith

I'm reassigning to Richard Smith to verify that the EC gets reset on update by the update code.

And if people still have problems after updating to A62 (and ensuring the EC has really been reset by removing power and the battery), please do add to this bug.

in reply to: ↑ description   Changed 8 years ago by bert

Same problem here, build 212, firmware B16. Battery was low, does not charge anymore (even after removing battery and power over night).

  Changed 8 years ago by jg

  • cc markf@… added
  • priority changed from normal to blocker

  Changed 8 years ago by pvanhoof

Same problem. OpenFirmware CL1 Q2A54 Q2A (B-Test)

  Changed 8 years ago by pvanhoof

I just upgraded using the Autoreinstall image (http://wiki.laptop.org/go/Autoreinstallation_image) and now the battery led is on (which makes me believe that it's working or at least that something about the battery changed, because before the upgrade it refused to be on).

The build is now at 213 and the firmware at Q2B16. I'm now going to upgrade to firmware Q2B17 as described on http://wiki.laptop.org/go/OLPC_Firmware_Q2B17

follow-up: ↓ 13   Changed 8 years ago by pvanhoof

The leds are on, but after a day of trying to charge the battery .. it didn't charge.

I haven't yet upgraded to Q2B17 (because the wifi was not working anymore for some obscure reason. But perhaps that has something to do with my wifi router. Anyway, I'll try upgrading today or tomorrow)

  Changed 8 years ago by PierreOssman

This seems to be hitting me as well. The battery is completely dead, and I get "No such device" when trying to check charge level, etc. in /sys.

I have only upgraded using the autoreinstall images. Currently I'm using the 212 image.

in reply to: ↑ 11 ; follow-up: ↓ 14   Changed 8 years ago by rsmith

Replying to pvanhoof:

The leds are on, but after a day of trying to charge the battery .. it didn't charge. I haven't yet upgraded to Q2B17 (because the wifi was not working anymore for some obscure reason. But perhaps that has something to do with my wifi router. Anyway, I'll try upgrading today or tomorrow)

Please do. The (bios)firmware should have zero effect on the wireless functionality and lots of battery stuff changed in later firmwares so we need testing on them to flush this out.

After you upgrade please try to charge it for a 12-24 hour period. We have had at least one battery here at OLPC that took a long time to charge. 3x-4x the normal charge time. So I need to see if you are just slow or if its really not charging.

Also while its charging boot up the laptop periodically and see if 'cat /sys/class/battery/psu_0/capacity_percentage give you a increasing number.

in reply to: ↑ 13   Changed 8 years ago by bert

Still not charging in stable B2 build (fw Q2B21, image 231).

  Changed 8 years ago by holtzman

I'm running Q2B21 image 239 on my laptop and upgraded another to Q2B21, image 231. Neither machine is charging its battery -- light is always out -- and the batteries appear dead. I've given them the 12-24 hours mentioned above.

  Changed 8 years ago by bert

Checking with an external charger seems to indicate my battery is completely dead. So I doubt a firmware update could fix my problem.

follow-up: ↓ 18   Changed 8 years ago by jg

  • cc wad added; markf@… removed
  • keywords relnote added
  • milestone changed from BTest-2 to BTest-3

We need to test that BTest-2 trickle charging will indeed recover a battery; I gather that this can take a day or two to do.

Note that since BTest-2 did not have the EC reset chip in it due to the power down problem found between preB2 and B2 that there is no guarantee the EC will come up sane; you may have to take the battery out and put it back in again after trickle charge to get the EC reset properly.

Richard, can you please test this is fixed for real?

in reply to: ↑ 17   Changed 8 years ago by rsmith

  • cc mlj added

Replying to jg:

We need to test that BTest-2 trickle charging will indeed recover a battery; I gather that this can take a day or two to do.

Richard, can you please test this is fixed for real?

This is not fixed. I setup a test on Friday and let it charge over the weekend. On Monday the batteries were still not charged. Reviewing the B2 schematic I can see nothing that would trickle charge the battery if the EC is not active. I asked Dave Woodhouse if he knew anything about the trickle charge. This prompted him to remember that the trickle charge did NOT make it into the B2 build. So add that to your list of things that need to go into B3.

follow-up: ↓ 20   Changed 8 years ago by fiorella

Some of our B2 laptops with Q2B73, image 239 also report No such device, and won´t start even if they´re plugged, unless we first remove the battery.

in reply to: ↑ 19   Changed 8 years ago by jg

  • keywords relnote, battery added; relnote removed
  • milestone changed from BTest-3 to Trial-1

Replying to fiorella:

Some of our B2 laptops with Q2B73, image 239 also report No such device, and won´t start even if they´re plugged, unless we first remove the battery.

Please try firmware version Q2B81; we thing this most of the problems, and Richard is working on further improvements.

  Changed 7 years ago by dds

I had a similar problem with a Q2B76 B1 laptop. When I got it, I upgraded it from an unknown older version to build 303 / Q2B76. Probably the older version could charge the battery, because when I got the laptop the battery worked for more than an hour. After the battery drained, it refused to recharge. The battery LED remained dark, and the laptop wouldn't work without a AC power for more than a minute. I upgraded to Q2B81. After the first reboot the battery LED changed to orange. However the battery wasn't recognised:

$ cat /sys/class/battery/psu_0/capacity_percentage
capacity_percentage: No such device
$ cat /sys/class/battery/psu_0/status
absent

After an hour's charging and a second reboot, the battery LED remained unlit, and the above commands gave the same results.

  Changed 7 years ago by jg

  • cc smithbone added

  Changed 7 years ago by rsmith

  • component changed from hardware to embedded controller

follow-up: ↓ 30   Changed 7 years ago by jg

  • priority changed from blocker to high

Richard will add details before closing here.

follow-ups: ↓ 26 ↓ 27   Changed 7 years ago by fiorella

We charged the unrecognized batteries using a 7.5 V - 230 mA DC power supply until they reached around 5.3 V. At this point the batteries were recognized by the laptopts, so we continued charging using laptops with firmware Q2B81. Now those batteries are working fine.

in reply to: ↑ 25   Changed 7 years ago by rsmith

Replying to fiorella:

We charged the unrecognized batteries using a 7.5 V - 230 mA DC power supply until they reached around 5.3 V. At this point the batteries were recognized by the laptopts, so we continued charging using laptops with firmware Q2B81. Now those batteries are working fine.

Thanks for the info. This is a B1 correct? If so thats exactly what I would expect. The cutoff for trickle charge is 5.2V but B1s do not have trickle charge hardware so you have to get the batteries over the hump.

I'm going to write up a wiki page describing all the battery issues and solutions. I'll close this bug when that page is done.

in reply to: ↑ 25 ; follow-ups: ↓ 28 ↓ 31   Changed 7 years ago by dds

Replying to fiorella:

We charged the unrecognized batteries using a 7.5 V - 230 mA DC power supply until they reached around 5.3 V. At this point the batteries were recognized by the laptopts, so we continued charging using laptops with firmware Q2B81. Now those batteries are working fine.

I followed the above procedure charging the battery until it reached 6.4 V. Firmware Q2B81, still doesn't recognise it (see the comment 03/26/07 05:29:57), although the laptop can operate on it (until it drains it again, I presume).

in reply to: ↑ 27 ; follow-up: ↓ 29   Changed 7 years ago by jg

You are using a B2 system?

Replying to dds:

Replying to fiorella:

We charged the unrecognized batteries using a 7.5 V - 230 mA DC power supply until they reached around 5.3 V. At this point the batteries were recognized by the laptopts, so we continued charging using laptops with firmware Q2B81. Now those batteries are working fine.

I followed the above procedure charging the battery until it reached 6.4 V. Firmware Q2B81, still doesn't recognise it (see the comment 03/26/07 05:29:57), although the laptop can operate on it (until it drains it again, I presume).

in reply to: ↑ 28   Changed 7 years ago by dds

Replying to jg:

Replying to dds:

Replying to fiorella:

We charged the unrecognized batteries using a 7.5 V - 230 mA DC power supply until they reached around 5.3 V. At this point the batteries were recognized by the laptopts, so we continued charging using laptops with firmware Q2B81. Now those batteries are working fine.

I followed the above procedure charging the battery until it reached 6.4 V. Firmware Q2B81, still doesn't recognise it (see the comment 03/26/07 05:29:57), although the laptop can operate on it (until it drains it again, I presume).

You are using a B2 system?

No, B1. S/N PCL10EN64600195

in reply to: ↑ 24   Changed 7 years ago by dds

Replying to jg:

Richard will add details before closing here.

Details are now available online at http://wiki.laptop.org/go/Battery_Charging

in reply to: ↑ 27   Changed 7 years ago by dds

Replying to dds:

Replying to fiorella:

We charged the unrecognized batteries using a 7.5 V - 230 mA DC power supply until they reached around 5.3 V. At this point the batteries were recognized by the laptopts, so we continued charging using laptops with firmware Q2B81. Now those batteries are working fine.

I followed the above procedure charging the battery until it reached 6.4 V. Firmware Q2B81, still doesn't recognise it (see the comment 03/26/07 05:29:57), although the laptop can operate on it (until it drains it again, I presume).

Problem resolved by reinitializing the battery EEPROM using batman.fth http://wiki.laptop.org/go/Battery_Charging#EEPROM_Init.

  Changed 7 years ago by jg

  • status changed from new to closed
  • resolution set to fixed

I think I can close this one now; directions are in the wiki and it's release noted where people can see it.

Yeah! Thanks to everyone for their hard work on ghis one.

Note: See TracTickets for help on using tickets.