Opened 7 years ago

Closed 7 years ago

#5454 closed defect (wontfix)

Rebase on Fedora 8

Reported by: bernie Owned by: dgilmore
Priority: normal Milestone: 8.2.0 (was Update.2)
Component: distro Version:
Keywords: Cc:
Blocked By: Blocking:
Deployments affected: Action Needed:
Verified: no

Description

I did a quick test to verify what problems we may face:

init 3
yum -y dist-upgrade --exclude poppler
init 5

Notes:

  • Going to init 3 is necessary to conserve memory, otherwise yum fights with sugar and cranks the system to death.
  • Excluding poppler prevents a dependency problem in our custom package.
  • We also need to avoid upgrading to the stock i586 kernel
  • NetworkManager 0.7 does not support the mesh
  • hald seems to be having problems starting from the initscripts
  • Input hotplug fails when X is being started by the olpc user. Althogh X is suid root, it seems hal or dbus check for the euid.

Change History (3)

comment:1 Changed 7 years ago by bernie

  • Milestone changed from Never Assigned to Update.2
  • Owner changed from jg to dgilmore

comment:2 Changed 7 years ago by cjb

It's not clear to me that we want to upgrade to Fedora 8 anytime soon, for the standard "supported platform vs. latest technology" reasons. It would help to know if there any concrete benefits to doing so. Let's talk about it before doing it.

comment:3 Changed 7 years ago by bernie

  • Resolution set to wontfix
  • Status changed from new to closed

I guess we should go with F9 rather than F8 for Update.2... All the information in this bug is out of date, thus closing as WONTFIX.

to answer cjb: the benefit of staying up-to-date with our upstream is that we do not end up with an unsupported, rotten distribution that we have to update manually for features, bug fixing and security fixes.

Note: See TracTickets for help on using tickets.