Opened 7 years ago

Closed 6 years ago

#5629 closed enhancement (fixed)

Add a disable screencorners option in Sugar-control-panel

Reported by: isforinsects Owned by: xelapond
Priority: high Milestone: 8.2.0 (was Update.2)
Component: sugar Version:
Keywords: frame hot corner popup touchpad Cc: Eben, erikos
Blocked By: Blocking:
Deployments affected: Action Needed:
Verified: no

Description

Screen corners are a hindrance to some, especially programmers who are not used to them. To improve productivity, there should be an option to temporarily disable screen corners.

Commenting out lines 56-57 of /usr/share/sugar/shell/view/frame/eventarea.py will accomplish this.

Change History (22)

comment:1 Changed 7 years ago by jg

  • Milestone changed from Never Assigned to FutureFeatures
  • Owner changed from marco to Eben

comment:2 Changed 7 years ago by Eben

  • Owner changed from Eben to marco

I guess I'm OK with this. Clearly this belongs within the control panel, if anywhere. I'd recommend implementing it as a slider that specifies the time delay (probably within the range of 0 to 1 seconds), with the extremes being instantaneous (the current behavior, though we might switch to a very short delay to prevent accidental invocation) and never.

comment:3 Changed 7 years ago by BHunsaker

The assumption that all hot corners should activate the frame should be reviewed. The eventual control panel should allow for designating different actions. For example, one such option might be to have a pop-up appear allowing me to switch directly to another already running activity.

Personally, I find the hot corners annoying. They are the easiest positions on the screen to position the mouse cursor which means I often go there accidentally. Together with the small track pad this makes the auto display of the frame a pain. Having a user adjustable time delay for activation will go a long way to improving the UI.

comment:4 Changed 7 years ago by ghopper

  • Keywords frame hot corner popup added

I vote for disabling them by default. There is no need to show the sugar frame on the activity screen.

See 5872 for more examples of why the hot corners feature should be eliminated.

comment:5 Changed 7 years ago by erikos

I only read this now, i guess to late for update.1. I absolutely agree that there should be an option to disable the hot corners (ideally in the way eben described to allow to specify the timeout). I think there is a need to show the frame on the activity screen but i think using the frame key to do this works more than great. The 'frame popping up' issue on accident is for me, and the people i showed the XO to, the most annoying and distracting in the user experience besides the palettes being persistent across zoom levels.

Having an option to adjust the hot corners behavior would improve usability of the XO a lot.

comment:6 Changed 7 years ago by bert

Me too. Even if it was just a control panel setting to disable mouse activation completely I'd be happy.

comment:7 Changed 7 years ago by jeffpk

Ideally, I think there should be two options.

One to set the amount of time the cursor has to remain in the corner to activate the frame to a custom setting.

A second to disable the corners entirely and map a keystroke to it instead.

comment:8 Changed 7 years ago by walter

There already is a key mapping (the Frame key in the upper right corner of the keyboard).

comment:9 follow-up: Changed 7 years ago by gnu

There would be a lot more use for popping up the Frame in the corners, if it actually had any function while running applications. I suggest moving the Close button, and other global activity controls, to the Frame. Then most apps won't need any "tabs" controlling their top bar (if they have one at all). See #4910.

comment:10 in reply to: ↑ 9 Changed 7 years ago by marco

  • Cc Eben added

Replying to gnu:

I suggest moving the Close button, and other global activity controls, to the Frame. Then most apps won't need any "tabs" controlling their top bar (if they have one at all). See #4910.

Yeah, this is part of the shell refactoring we are planning to do for Update.2. I think Eben is working on a wiki page to document the changes.

comment:11 Changed 7 years ago by homunq

duplicate of 5872. I think that the description and discussion there are better but this has a lower number - so which should I mark as duplicate?

comment:12 Changed 7 years ago by ixo

I think having options for each corner would be great.
(RT,LT,RB,LB = could each be one of many options 1) no activation, 2) time delay: .5,1,5 sec, 3) instant activation, 4) popup to configure Frame activation, or 5 sec in any corner to bring up config.

So lets say, I like having frame activation in Left-Bottom, but turn off the rest of corners.
LB = 0 sec, all others NONE ==> :-)

comment:13 Changed 7 years ago by AlbertCahalan

Remember that kids are the primary audience.

Kids have terrible trouble with accidental frame activation. Therefore, this needs to be disabled by default.

If some older people happen to like screen corner frame activation (Eben, anybody else?) then they can enable it. By default though, it needs to be off.

comment:14 Changed 7 years ago by erikos

  • Cc erikos added

comment:15 Changed 7 years ago by ixo

  • Milestone changed from FutureFeatures to Update.2
  • Priority changed from low to high

Also remember that there is already a 'frame' button on the keyboard, and Alt-F will bring it up too. Turn off 'auto-pop-up' feature ! It already interferes with many activity operations... try using 'Colors!' ... ouch! Very painful !

(Maybe two-three quick taps of the frame button can toggle auto feature on/off ??)

comment:16 Changed 7 years ago by HoboPrimate

I vote for the current behavior, with an option in the control-panel to deactivate the auto hiding/showing of the frame. I think the current way is for it to be discoverable, as it plays an important role in the ui. Also, accidental activation of the frame has a lot to do with the touchpad still becoming crazy sometimes.
Perhaps there should be a place where kids themselves could make their voices heard on this an other matters, so that grown-ups aren't making choices on wrong presumptions (one of which is sometimes underestimating their abilities).

comment:17 Changed 7 years ago by bert

How about deactivating the corners for the session once the frame key has been pressed?

For someone using the corners exclusively nothing would change. Same for someone using the frame key exclusively (but no more accidental activations).

comment:18 Changed 7 years ago by HoboPrimate

Or a long-press of the frame key could deactivate the frame? Or Fn+frame key ? In either case, some info should probably be displayed to the user, perhaps as a system notification, that the frame is now not or is back in auto-hiding mode.

comment:19 Changed 7 years ago by HoboPrimate

I like the idea of press-and-hold the frame key to change the Frame activation behavior, as it is a bit similar to how the shutdown button works. With the shutdown button, you press just once, and the laptop apparently shuts down (actually suspends), but is turned on (awaken) with just a key press, touchpad action or shutdown button press. A longer press of the shutdown button shuts down the laptop for good.
The Frame could behave similarly to this. You press the frame key, and the frame shows itself, and hides only after the arrow cursor enters (if not already inside) and exits it (this is not the current behavior, but was suggested by Eben in another ticket). A longer press of the frame key makes the Frame appear as well, but this time further operations to it are only done through that key, until another long-press reverts the behavior.

comment:20 Changed 7 years ago by mstone

  • Keywords touchpad added

comment:21 Changed 7 years ago by xelapond

  • Owner changed from marco to xelapond

comment:22 Changed 6 years ago by marco

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.