Opened 7 years ago

Closed 3 years ago

#5835 closed enhancement (fixed)

readd 3 button mouse emulation

Reported by: martianpenguin Owned by: dsd
Priority: high Milestone: 11.3.0
Component: olpc-utils Version:
Keywords: x mouse emulation Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: no action
Verified: no

Description

Is there a reason why 3 button mouse emulation cannot be implemented? This would be helpful for copy/paste especially.

Attachments (2)

20-olpc-mouse.conf (325 bytes) - added by dsd 3 years ago.
config for xorg.conf.d
diff.txt (2.9 KB) - added by dsd 3 years ago.
diff between Xorg log, before and after

Download all attachments as: .zip

Change History (9)

comment:1 Changed 7 years ago by jg

  • Milestone changed from Never Assigned to Update.1
  • Priority changed from normal to high

Bernie, I would have thought we're already doing so...

comment:2 Changed 3 years ago by dsd

  • Action Needed set to never set
  • Milestone changed from 8.2.0 (was Update.2) to 11.2.0-final
  • Owner changed from bernie to dsd
  • Summary changed from add 3 button mouse emulation to readd 3 button mouse emulation

We had this working in 10.1 and previous. S Page (http://permalink.gmane.org/gmane.linux.laptop.olpc.devel/31566), Martin and Paul all agree it was working.

For some reason it broken for 11.2. As far as I can see, X defaults to having this functionality disabled by default, I don't know how it got enabled in 10.1 (perhaps unintentionally). The reason that it works on my normal desktop in GNOME is because GNOME tweaks that setting at runtime, perhaps based on my user profile.

It can be fixed by shipping a small InputClass definition in /usr/share/X11/xorg.conf.d that force-enables this option.

I confirmed that this fixes the problem, and I also did a diff of Xorg.0.log before and after to check for any other obvious side effects - none noted.

As a regression with a trivial fix I'm proposing this for 11.2.0.

Changed 3 years ago by dsd

config for xorg.conf.d

Changed 3 years ago by dsd

diff between Xorg log, before and after

comment:3 Changed 3 years ago by dsd

  • Action Needed changed from never set to package
  • Component changed from x window system to olpc-utils
  • Milestone changed from 11.2.0-final to 11.3.0

Due to the late stages of 11.2.0 this is moved to 11.3.0 based on IRC discussion: this is only a minor regression that nobody noticed until late in the cycle, the same functionality (copy/paste) is also available elsewhere.

comment:4 Changed 3 years ago by pgf

well, for the record, i noticed it quite a long time ago. but there are so many things that get changed simply because it's the new fedora way, or the new upstream way, that filing a bug didn't seem worthwhile.

comment:5 Changed 3 years ago by dsd

  • Action Needed changed from package to add to build

comment:6 Changed 3 years ago by dsd

  • Action Needed changed from add to build to test in build

test in 11.3.0 build 1

comment:7 Changed 3 years ago by greenfeld

  • Action Needed changed from test in build to no action
  • Resolution set to fixed
  • Status changed from new to closed

Verified that first button highlight and third button paste worked in the Terminal activity on both XO-1 and XO-1.5 with 11.3.0 os1.

Note: See TracTickets for help on using tickets.