Ticket #5840 (closed defect: fixed)

Opened 7 years ago

Last modified 6 years ago

content bundle does not load

Reported by: chihyu Owned by: sj
Priority: normal Milestone: Update.1
Component: library Version:
Keywords: Cc: kimquirk, jg, marco, mako
Action Needed: Verified: no
Deployments affected: Blocked By:
Blocking:

Description

build: joyride-1489

the following occurred in all 3 machines tested:

* bible-en.xol could be downloaded, and the entry showed up in the left column when launching Browse

* when clicking on the net bible, the browser showed

 File Not Found
 The file /home/olpc/Library/bible-en/bundle_index.html cannot be found. Please check the location and try again.

the URL in the address field was

file:///home/olpc/Library/bible-en/bundle_index.html

* all the chapters (html files) were extracted to /home/olpc/Library/bible-en/files/ but there was no bundle_index.html, only index.html

* net bible works fine on build 653; is there a new content bundle for joyride builds?

Change History

Changed 7 years ago by jg

  • cc marco added
  • milestone changed from Never Assigned to Update.1

Changed 7 years ago by chihyu

build: joyride-1489

tested the new bundle http://dev.laptop.org/~sj/bible-en.xol

downloaded the file to USB drive

clicking on the journal entry would launch the Etoys activity.

had to manually type the file location in Browse activity in order to install.

however, the new content was not added to /home/olpc/Library/


removed the older version of bible-en installed on the XO by rm -r /home/olpc/Library/bible-en

but the "net bible" entry still appeared in the browser even after rebooting.

reinstalled the new bundle by manually typing the file location in Browse activity, but the new content still was not added to /home/olpc/Library/

Changed 7 years ago by jg

  • owner changed from sj to marco
  • component changed from library to sugar

Changed 7 years ago by marco

  • cc mako added
  • owner changed from marco to sj
  • component changed from sugar to library

AFAICT sugar is working fine here.

The bundle contains only index.html but the generated index looks for bundle_index.html. I don't know which is right.

Note that sugar currently check for index.html to ensure the bundle is valid, so if that has been renamed to bundle_index.html, sugar will have to updated too (reassign back to me in that case).

Changed 7 years ago by mako

  • owner changed from sj to mako
  • priority changed from blocker to normal
  • status changed from new to assigned

This is not a problem with sugar, or with the content library script. The problem is with the bible-en.xol bundle which is being used to test. The bible package is a Ship.2 generation package and will need to be updated to the new format.

I can do that (and update the documentation) when I get back to Boston. I am leaving (from Tokyo) in about two hours and will get to this over the weekend.

In any case, this bug is not (AFAICT) with any code on the XO and is not a blocker.

Changed 7 years ago by mako

  • owner changed from mako to sj
  • status changed from assigned to new

Changed 7 years ago by jg

Are we going to blow off all Ship.2 bundles? Seems harsh, but if we need to do so, better now than later...

Or is this specific to this bundle?

Changed 7 years ago by sj

This should be fixed. I've patched library-common and the ship.2 bundles so that the old bundles will continue to work.

The only bundles that should work crudely are the default bundles in ship.2, which (if it were possible to export them and import them to an update.1 machine) have some broken links on their index pages. In practice, you can only do this by copying those older directories over by hand from an older machine to a newer one, which users are unlikely to attempt, or by doing a conservative olpc-update from an old build and somehow not overwriting /usr/share/activities.

Changed 7 years ago by chihyu

With joyride-1537, content bundle could only be manually loaded. Clicking on the .xol file from Browse does nothing. To be more specific, in order for net bible to be accessible from Browse, one has to:

  • mkdir /home/olpc/Library
  • unzip /media/usb_name/Bible-en.xol -d /home/olpc/Library
  • /usr/share/library-common/make_index.py

Will these steps be automated for future joyride builds, so that users don't have to type the commands?

Changed 6 years ago by sj

  • status changed from new to closed
  • resolution set to fixed

This has been fixed. There is still an outstanding bug to improve mimetype recognition/guessing when resuming a zip file with an .xo[l] extension.

Note: See TracTickets for help on using tickets.