Ticket #5841 (closed defect: fixed)

Opened 7 years ago

Last modified 6 years ago

es.map is broken for XO keyboards

Reported by: walter Owned by: bernie
Priority: blocker Milestone: 8.2.0 (was Update.2)
Component: keyboards Version:
Keywords: console release? Cc: jg, walter, bernie, dgilmore, arjs
Action Needed: never set Verified: no
Deployments affected: Blocked By:
Blocking:

Description

The file /lib/kbd/keymaps/i386/qwerty/es.map.gz is not configured properly for OLPC Spanish keyboards. This prevents one from typing certain keys, such as < and > in the console. There is a patched es.map file at http://laptop.org/es.map.gz

Not sure how best to put this patch in: as a replacement to the existing es.map.gz or, perhaps, as a new file: es-ar.map.gz, with the corresponding reassignment of the default value for KEYTABLE in /etc/sysconfig/keyboard for ES machines. Bernie, your call.

Attachments

pt.map.gz (0.8 kB) - added by walter 7 years ago.
es.map.gz (0.9 kB) - added by walter 6 years ago.

Change History

  Changed 7 years ago by walter

I am guessing Portuguese is also a problem. I'll take a look when I come up for air.

  Changed 7 years ago by jg

  • cc bernie added
  • milestone changed from Never Assigned to Update.1

Heh... Shall I get you another tank of Air? And don't get the bends coming up to the surface...

As a console, as opposed to X bug, I expect this to be Update.1 fodder rather than a patch candidate.

  Changed 7 years ago by walter

certainly not a patch candidate...

  Changed 7 years ago by walter

Bernie,

I've attached new files for Spanish and Portuguese. The difference in the Spanish file is that I think I am now also properly mapping control and alt keys. Please confirm.

Changed 7 years ago by walter

  Changed 7 years ago by chihyu

Will the new .map files be included in future joyride builds as well? I am now running joyride 1537, but still have manually loadkeys [.map file copied in the USB drive].

  Changed 7 years ago by jg

  • priority changed from high to blocker

Bernie, I'd like to get these into update.1 please...

  Changed 6 years ago by bernie

Sorry for this very long delay. Copying from my last mail to Walter to keep the bug up to date:

The problem is just that we do not load our customized keymaps because a clean integration in the kbd package would need a bit of work to detect OLPC at run-time and prepend a new "olpc/" directory to the search path in this case.

To make it happen in Update.1 quickly, I vote for a quick & dirty Pilgrim hack: we'd basically just have to overwrite es.map.gz and pt.map.gz in /lib/kbd/keymaps/i386/qwerty/ with the versions attached to the bug.

This will gain us time to find out how to integrate olpc keymaps properly with the package maintainer in the next release cycle.

follow-up: ↓ 9   Changed 6 years ago by cscott

Did this get fixed in xkeyboard-config 1.1-15.20071130cvs.olpc2 ?

in reply to: ↑ 8   Changed 6 years ago by bernie

Replying to cscott:

Did this get fixed in xkeyboard-config 1.1-15.20071130cvs.olpc2 ?

No, this bug is about the *console* keymap, which is in the kbd package.

  Changed 6 years ago by Blaketh

  • keywords release? added

  Changed 6 years ago by dgilmore

kbd-1.12-23.olpc2 just built which puts the files from this report into /lib/kbd/keymaps/i386/qwerty/

  Changed 6 years ago by dgilmore

  • cc dgilmore added

  Changed 6 years ago by dgilmore

The files i initially got were bad. corrected in kbd-1.12-24.olpc2 I have verified on my spanish laptop that the console has the correct mappings. this is going into a update.1-702 build. i have found one missing keymap. the altgr for the button with ]} on it does not work in the console. all the rest were ok.

  Changed 6 years ago by walter

61c61 < keycode 43 = bracketright braceright ---

keycode 43 = bracketright braceright section

(See attached file)

Changed 6 years ago by walter

  Changed 6 years ago by mstone

Walter,

We built a new kbd package with your latest es.map.gz but discovered several problems when trying it out on machines with spanish keyboards. I'll write "{image printed on keyboard} -> {what showed up on the screen}".

section sign -> masculine ordinal identifier
masculine ordinal identifier -> parallel to
feminine ordinal identifier -> logical negation
logical negation -> 1/4
inverted exclamation point -> ???
inverted question mark -> ???
diaresis -> inverted question mark
degree symbol -> ???

  Changed 6 years ago by dgilmore

On my MP machine, they all were correct. and symbol showed up

  Changed 6 years ago by mstone

Indeed, my results were on a B4 with a Uruguayan keyboard and some on a B4 with an Argentinian keyboard. If necessary, I'll reanalyze on a Spanish MP tomorrow.

  Changed 6 years ago by mstone

(The silk screening is the same on all three machines, though). Also, we need to remember to update the wiki page for the keyboard layout when we're done.

  Changed 6 years ago by sj

I tried this on an MP with Uruguayan keyboard, and the keymapping seems to be flawless. Hopefully this is a B4-specific problem.

(The silk screening here is also the same as on the B4.)

  Changed 6 years ago by arjs

  • cc arjs added

  Changed 6 years ago by gnu

Is this totally fixed and tested in recent Update.1 builds (703 or 70x)? If not, we should fix and test to reduce problems with the possible summer European G1G1 program.

(Are keyboards in Spain identical to Spanish-language keyboards in Latin America? If not, we'd need Yet Another keyboard layout and keymaps.)

  Changed 6 years ago by cscott

  • status changed from new to closed
  • next_action set to never set
  • resolution set to fixed

I regularly use the spanish keyboard, I can attest that this has been fixed for a while.

Note: See TracTickets for help on using tickets.