Ticket #5846 (closed defect: fixed)

Opened 7 years ago

Last modified 6 years ago

olpc-netstatus gives "command not found"

Reported by: chihyu Owned by: bernie
Priority: high Milestone:
Component: security Version:
Keywords: Cc: yani
Action Needed: Verified: no
Deployments affected: Blocked By:
Blocking:

Description

Build: Joyride 1489

* machine is connected to mesh network (school server)

* Hit ctrl-alt-mesh

* login as olpc

* run olpc-netstatus, see the following:

/usr/bin/olpc-netstatus: line 47: ifconfig: command not found 
/usr/bin/olpc-netstatus: line 55: ifconfig: command not found 
/usr/bin/olpc-netstatus: line 117: iwconfig: command not found 
/usr/bin/olpc-netstatus: line 37: iwconfig: command not found 
/usr/bin/olpc-netstatus: line 37: iwconfig: command not found

Attachments

olpc-netstatus.new (3.6 kB) - added by wad 7 years ago.

Change History

Changed 7 years ago by kimquirk

  • cc yani added
  • priority changed from normal to high

Changed 7 years ago by cjb

The olpc user doesn't have /sbin or /usr/sbin in its path. The olpc-netstatus script should be changed to include those paths.

Changed 7 years ago by wad

Changed 7 years ago by wad

I attached a version of olpc-netstatus which fixes most of the problems introduced by moving to joyride. There are still a number of places where this script uses relative position in a command output --- which will break over time!

Another problem was the use of msh0_rename instead of msh0 in joyride. This smells like a hack.

Changed 7 years ago by mstone

  • owner changed from mstone to bernie

Reassigning to bernie, since olpc-netstatus is provided by olpc-utils.

Changed 7 years ago by dsd

This problem does not occur on joyride-1520 because /sbin and /usr/sbin are now in the olpc user's default path.

The bug does exist in update1-674.

Changed 7 years ago by bernie

Should be fixed in update.1 once we import latest olpc-utils for #5033.

Changed 7 years ago by bernie

  • status changed from new to closed
  • resolution set to fixed

Oh, dgilmore just did it in update.1-677. Closing as fixed.

Changed 6 years ago by gregorio

  • milestone deleted

Milestone Never Assigned deleted

Note: See TracTickets for help on using tickets.