Ticket #5851 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

activities won't load

Reported by: chihyu Owned by: chihyu
Priority: high Milestone: 8.2.0 (was Update.2)
Component: security Version:
Keywords: rainbow-integration Cc: kimquirk, mstone, bernie, sj
Action Needed: never set Verified: no
Deployments affected: Blocked By: #5626
Blocking:

Description

Three activities (Implode, XaoS, and Maze) were downloaded and installed from http://wiki.laptop.org/go/Activities via Browse activity.

* One machine with joyride-1489, clean installed, was able to run all three activities.

* One machine upgraded from build 653 to joyride-1489 using "olpc-update joyride-1489" could not run any of the three activities. The activity icon was flashing in the donut for about 1 minute, and then disappeared automatically.

* One machine upgraded from build 653 to joyride-1489 using "olpc-update --usb" could not run any of the three activities. The activity icon was flashing in the donut for about 1 minute, and then disappeared automatically.

Attachments

com.jotaro.ImplodeActivity-1_net.log (6.2 kB) - added by chihyu 6 years ago.
Implode - net update
com.jotaro.ImplodeActivity-1_usb.log (6.2 kB) - added by chihyu 6 years ago.
Implode - usb update
org.codewiz.XaoS-1_net.log (6.0 kB) - added by chihyu 6 years ago.
XaoS - net update
org.codewiz.XaoS-1_usb.log (6.0 kB) - added by chihyu 6 years ago.
XaoS - usb update
vu.lux.olpc.Maze-1_net.log (6.0 kB) - added by chihyu 6 years ago.
Maze - net update
vu.lux.olpc.Maze-1_usb.log (6.0 kB) - added by chihyu 6 years ago.
Maze - usb update

Change History

Changed 6 years ago by chihyu

Implode - net update

Changed 6 years ago by chihyu

Implode - usb update

Changed 6 years ago by chihyu

XaoS - net update

Changed 6 years ago by chihyu

XaoS - usb update

Changed 6 years ago by chihyu

Maze - net update

Changed 6 years ago by chihyu

Maze - usb update

  Changed 6 years ago by chihyu

  • cc kimquirk added

Since the clean installed machine was able to run all three games, and the last line of every attached log file ended with

Permission denied: '/home/olpc/Activities/[activity_name].activity'

I suspect that upgrading from an older build caused this issue.

  Changed 6 years ago by mstone

  • cc mstone, bernie added
  • keywords rainbow-integration added

I think this is basically a dup of #4928. Fortunately, Bernie and I worked on some improvements to olpc-utils today that we believe will fix this problem. I'll be sure to test this claim as I attempt to qualify our changes this evening.

  Changed 6 years ago by mstone

  • blockedby 5626 added

Should be fixed in joyride-1508 and later.

  Changed 6 years ago by jg

  • milestone changed from Never Assigned to Update.1

follow-up: ↓ 6   Changed 6 years ago by jg

  • owner changed from mstone to chihyu

Could you please reverify this in a current joyride?

in reply to: ↑ 5   Changed 6 years ago by chihyu

  • cc sj added

Replying to jg:

Could you please reverify this in a current joyride?

build: joyride-1520

Three activities (Implode, XaoS, and Maze) were downloaded from http://wiki.laptop.org/go/Activities and installed locally. (the files were downloaded to a USB drive and copied over to /home/olpc/)

* The clean installed machine was not able to install any of the three activities. (/home/olpc/Activities/ could not be created)

* One machine upgraded from joyride-1489 using "olpc-update joyride-1520" kept the older version of these activities (i.e. installed while running 1489). It had no problem running Implode and Maze. It could run XaoS but wouldn't terminate the program after hitting Ctrl-q. The activity window did disappear, but the icon remained flashing "Starting" in the donut for about a minute, and the disappeared automatically.

I tried installing XaoS again with the file just downloaded today, but the XaoS directory was not affected at all (judging from the date of the files).

* One machine upgraded from joyride-1489 using "olpc-update --usb" did not keep the older version of these activities (i.e. installed while running 1489), and it was not able to install any of the three activities. (/home/olpc/Activities/ could not be created)


I suspect that this is due to the wrong mime type of the content bundle (#5840?), but I cannot confirm.

  Changed 6 years ago by chihyu

Also, clicking directly on the .xo files from the Journal would launch Etoys.

  Changed 6 years ago by chihyu

  • status changed from new to assigned

fixed as of build 687

  Changed 4 years ago by bernie

  • status changed from assigned to closed
  • next_action set to never set
  • resolution set to fixed

Did you mean to close this bug?

Note: See TracTickets for help on using tickets.