Opened 7 years ago

Closed 7 years ago

#5925 closed defect (fixed)

olpc-netstatus "substring expression < 0" error

Reported by: dsd Owned by: dsd
Priority: high Milestone: Update.1
Component: distro Version:
Keywords: review? Cc:
Blocked By: Blocking:
Deployments affected: Action Needed:
Verified: no

Description

Joyride 1520, reproduced on 2 B4s. Also reproduced on update1-674 on a MP system.

  1. Login as olpc on virtual terminal
  2. run "sudo su -"
  3. run "olpc-netstatus"

Final lines of output:

Telepathy: salut
Jabber:

/usr/bin/olpc-netstatus: line 118: $((${#i}-59)): substring expression < 0

Attachments (2)

0001-olpc-netstatus-Fix-ESSID-parsing.patch (862 bytes) - added by dsd 7 years ago.
olpc-netstatus fix
olpc-netstatus.0.3 (3.7 KB) - added by yani 7 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 7 years ago by dsd

I should also note that this is a regression, it does not happen in ship 2.2

Changed 7 years ago by dsd

olpc-netstatus fix

comment:2 Changed 7 years ago by dsd

  • Keywords review? added

It's due to the new wireless driver which doesn't provide a nickname, displayed on the same line in iwconfig.

comment:3 follow-up: Changed 7 years ago by jg

  • Milestone changed from Never Assigned to Update.1
  • Priority changed from normal to high

comment:4 in reply to: ↑ 3 Changed 7 years ago by yani

  • Resolution set to fixed
  • Status changed from new to closed

The code of olpc-netstatus had a couple of lines that were prone to such crashes. A new version is just available to solve this bug, and is stable against future changes of the driver.

dsd,
thanx for the patch, but the dependence on output relative position should be changed entirely as well.

i attach the new version

Changed 7 years ago by yani

comment:5 follow-up: Changed 7 years ago by chihyu

  • Resolution fixed deleted
  • Status changed from closed to reopened

Is the patch going to be included in future joyride builds? Joyride 1537 still has the same issue.

comment:6 in reply to: ↑ 5 Changed 7 years ago by chihyu

Update.1 (684) also has the same issue.

Replying to chihyu:

Is the patch going to be included in future joyride builds? Joyride 1537 still has the same issue.

comment:7 follow-up: Changed 7 years ago by bernie

  • Owner changed from bernie to ApprovalForUpdate
  • Status changed from reopened to new

Fixed in olpc-utils-0.67-1.

comment:8 in reply to: ↑ 7 Changed 7 years ago by chihyu

The same issue still appears in build Update.1 (687). I assume this has not been included in the build?

Replying to bernie:

Fixed in olpc-utils-0.67-1.

comment:9 Changed 7 years ago by jg

  • Owner changed from ApprovalForUpdate to dgilmore

Approved...

comment:10 Changed 7 years ago by dgilmore

  • Owner changed from dgilmore to dsd

please test build 690

comment:11 Changed 7 years ago by dsd

  • Resolution set to fixed
  • Status changed from new to closed

seems fine in 691

Note: See TracTickets for help on using tickets.