Ticket #5963 (closed defect: duplicate)

Opened 7 years ago

Last modified 6 years ago

Laptop fails to reliably connect with school mesh portal

Reported by: wad Owned by: dcbw
Priority: high Milestone: Update.1
Component: network manager Version:
Keywords: WLAN Cc: dcbw, Collabora
Action Needed: Verified: yes
Deployments affected: Blocked By:
Blocking:

Description

At 1CC, it is not unusual for a laptop to fail to associate with a school server on a particular mesh. Yet, when tried for a second or third time, it works.

The laptop is associating fine with the server at the radio level (it shows the proper essid).

Looking at the server logs, it is receiving the DHCP discovery packets, and is responding with an offer. The laptop does not respond with a DHCP request.

I believe that this is probably due to our decreasing the timeout on DHCP discoveries (to speed up scanning through all channels). Unfortunately, this results in some number of laptops forming simple meshes even when a school server is present.

Seen using laptop build 1489 and server build 141.

Change History

Changed 7 years ago by jg

  • milestone changed from Never Assigned to Update.1

Changed 6 years ago by wad

  • cc dcbw added
  • verified set

This is still real problem. When testing startup with 29 laptops, around a third of them (seven or eight) didn't find the school mesh portal.

http://wiki.laptop.org/go/Collaboration_Network_Testbed#Test_0317D

http://wiki.laptop.org/go/Collaboration_Network_Testbed#Test_0317E

I suggest backing off on the DHCP timing tweaks added to make trying all three channels faster.

Changed 6 years ago by morgs

  • cc Collabora added

Can you run with logs enabled? presenceservice.log would help to see what happens.

Changed 6 years ago by wad

This is not a presence service problem. This is a problem with the underlying network. The laptop never uses the DHCP offers sent to it, and decides to join a simple mesh instead.

Changed 6 years ago by wad

  • status changed from new to closed
  • resolution set to duplicate

Closed as a duplicate of #4153.

Note: See TracTickets for help on using tickets.