Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#5987 closed defect (fixed)

gnash won't navigate in pbskids.org

Reported by: jg Owned by: rsavoye
Priority: blocker Milestone: 8.2.0 (was Update.2)
Component: gnash-plugin Version:
Keywords: joyride-2176:+ Cc: erikos, tomeu, dsd
Blocked By: Blocking:
Deployments affected: Action Needed: finalize
Verified: no

Description

on PBSkids.org...

Even after pressing the X.

Build 1531.

Note this has the ff3b2 based browser, but I believe I saw this even before the updated browser. So I'm suspecting gnash first. Simon, please confirm this please, though...

Change History (8)

comment:1 Changed 7 years ago by erikos

I tested another flash site (taz.de) where i could see the flash animation as expected. When clicking the x on pbskids.org the page stays black a long time, then i am presented with the animation and i can get the gnash options when i do a right mouse click but it does not seem as if my interaction on the animation itself does anything, or maybe i do not get the UI :).

I tested with the old browser and it has the same behavior.

comment:2 Changed 7 years ago by tomeu

  • Cc tomeu added

The X in the placeholder should just delete the embed from the page, so you can dismiss flash animations that cover some part of the screen.

For starting the animation, you should click somewhere else inside the placeholder.

See #4968.

comment:3 Changed 7 years ago by tomeu

So, the flash file seems to load, but interaction with it doesn't work.

When I click on Music, Games, etc., I get this error from gnash:

3163] 15:00:14: get url: target=, url=http://pbskids.org/fromkids/games/index.html?campaign=fkag_gm (/fromkids/games/index.html?campaign=fkag_gm), method=0 (sendVars:0, loadTarget:0, loadVariable:0)
3163] 15:00:14: SECURITY: Load from host pbskids.org granted (default).
3163] 15:00:14: Launching URL... firefox -remote 'openurl(http://pbskids.org/fromkids/games/index.html?campaign=fkag_gm)'
sh: firefox: command not found

So it looks like gnash wants to open a popup by calling the firefox binary, which we don't ship.

Would be interesting to install adobe's plugin and strace -p it so we see how it is launching a new browser window. Then we could open a ticket in upstream gnash about improving their support for popups so it works also in embedded xulrunner.

comment:4 Changed 7 years ago by gnu

  • Summary changed from gnash doesn't seem to run to gnash won't navigate in pbskids.org

Filed as a Gnash bug today at https://savannah.gnu.org/bugs/index.php?22238

comment:6 Changed 6 years ago by dsd

  • Action Needed set to finalize
  • Cc dsd added
  • Keywords joyride-2176:+ added

This is fixed in 8.2 through the gnash upgrade

comment:7 Changed 6 years ago by gnu

I tested this on joyride 2181. Navigating pbskids.com works for me; I even got into a flash game, 3 Puck Chuck. The game itself didn't work (I couldn't pull the rubberband out of the pucks), but navigation worked fine. Another game (Alphabet Falls) flashes the screen at about 0.5hz but doesn't seem to do anything else.

The mouse cursor seems to leave funny turds in both 3 Puck Chuck and in taz.de's flash movie. That's yet a different problem.

I recommend deleting the spam comment (by airforce1), banning them, and closing this bug.

comment:8 Changed 6 years ago by dsd

Can you reproduce the mouse turd problem on joyride-2207? That may have been a problem with the x server.

comment:9 Changed 6 years ago by gregorio

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.