Ticket #6105 (closed defect: fixed)

Opened 7 years ago

Last modified 6 years ago

New EC firmware in q2d09 seems wonky?

Reported by: supersat Owned by: rsmith
Priority: high Milestone:
Component: embedded controller Version: Development firmware
Keywords: Cc: wad, wmb, kweidner, mtd
Action Needed: never set Verified: no
Deployments affected: Blocked By:
Blocking:

Description

After updating to q2d09, I decided to check out the changes to the self-test. To my surprise, holding down the left rocker button while pressing the power button did nothing -- the machine didn't turn on. Another time, it turned on, only to completely shut down (with the green battery light going out) a few seconds after I released the rocker button. Another time, it failed to turn on, and the battery light blinked off and on.

The system also occasionally thinks the alt-gr button is down, despite me never hitting it or having issues with it being stuck with earlier firmwares. This is much less repeatable, so I don't know for sure if it's an issue with q2d09.

Change History

Changed 7 years ago by supersat

The key sticking issue is happening with more regularity now. Whenever it happens, I get these kinds of messages in dmesg:

[ 366.572479] atkbd.c: Unknown key pressed (translated set 2, code 0x9f on isa0060/serio0). [ 366.580685] atkbd.c: Use 'setkeycodes e01f <keycode>' to make it known.

[ 2485.158140] atkbd.c: Unknown key pressed (translated set 2, code 0x8e on isa0060/serio0). [ 2485.166344] atkbd.c: Use 'setkeycodes e00e <keycode>' to make it known.

[ 2218.485992] atkbd.c: Unknown key pressed (translated set 2, code 0x95 on isa0060/serio0). [ 2218.494195] atkbd.c: Use 'setkeycodes e015 <keycode>' to make it known.

[ 3056.831236] atkbd.c: Unknown key released (translated set 2, code 0xe0 on isa0060/serio0). [ 3056.839524] atkbd.c: Use 'setkeycodes e060 <keycode>' to make it known.

Changed 7 years ago by walter

  • cc wad added

There had been a handful of keyboards that had some sticky keys in the bottom row that sounds similar to what you are now experiencing; initial diagnosis was that this was a hardware problem. It is curious that it would be induced by a firmware upgrade.

Changed 7 years ago by supersat

I believe this problem is different than the usual sticky key problem. I think one of the game keys (the O) also became stuck (but this is very hard to reproduce). q2d09 is so much worse than q2d08 (in terms of sticky/oddly behaving keys) that I downgraded back to q2d08.

i haven't closely been following the usual sticky key issues, but I wouldn't rule out a software bug. The bottom keys probably get a lot more blame than the others since keys do not repeat inside sugar, but modifier keys stay active.

Changed 7 years ago by walter

  • cc wmb added

#6103 seems to suggest that there are additional software problems as well that are more systemic.

Changed 7 years ago by mtd

I can get the game/directional keys to stick instantly in Browse or Read, just by pressing them. q2d09 and joyride-1551. Going to downgrade to q2d08 to see if it's joyride or the firmware (I upgraded both in one series of reboots, as I had had such good experiences with upgrades before).

Changed 7 years ago by mtd

Downgrading to q2d08 fixed my problem. Not sure if you want another ticket for it:

* flash q2d09 * olpc-update -vr joyride-1551 * Launch Browse and go to a page that renders to a size larger than the screen - press the rotate-screen button: nothing will happen, or the page will scroll all the way down, as if the down arrow / directional pad were being held down. - press the down d-pad; the screen will rotate, or scroll to the top one line at a time, or scroll to the bottom, one line at a time.

I can re-upgrade to q2d09 if you want more details / test scripts. I have also seen the alt-gr-stuck problem twice with q2d09, and I can't remember if I ever had seen it before then. Switching to a different vt and then back usually fixed it, which is the main reason I didn't think it was the sticky-alt hardware problem I've seen discussed a lot.

Changed 7 years ago by kweidner

  • priority changed from normal to high

I can confirm that the rocker/game keys are buggy with firmware q2d09, and I didn't have problems with the g1g1 shipped firmware so I don't think it's a problem with the keys themselves.

How to reproduce:

- in Write, start typing normally. Once you hit the rocker key, that key gets stuck on autorepeat permanently

- boot into OpenFirmware

- at the ok prompt: test /keyboard

- test pressing a normal key (such as "space"), confirm that the on-screen key turns light blue only briefly

- press the rocker or a game key, and the on-screen key stays light blue and never turns off. (These keys don't have direct screen representation, the on-screen keys that light up are 2/8 and 4/8 of the middle slider key, Erase, and the "L" key)

- after pressing all 4 rocker directions and all game keys, no other keys react, including ESC, and I need to power off to get out of the test

Raising priority to "high", a flaky keyboard makes the machine largely unusable.

Changed 7 years ago by kweidner

  • cc kweidner added

Changed 7 years ago by mtd

  • cc mtd added

Changed 7 years ago by kweidner

confirmed also that downgrading to q2d08 fixes the problem, the keys work as expected.

On q2d09, I had also gotten a stuck AltGr key when switching between applications (I was not using that key), and xev showed multiple distinct KeyPress/KeyRelease events for the rocker and game buttons.

Changed 7 years ago by mtd

Think this will be fixed for Update.1?

Changed 7 years ago by eeksock

Confirmed that with q2d09, the following steps would trigger the autorepeating nearly 90% of the time:

- launch a PDF from reader - on the Read tab, go to a page in the middle of the document - hit X to go down. You may need to hit X and O a couple of times ---> on my machine, this caused the View activity to continuously page up or down through the PDF ---> if I somehow manage to switch to Terminal, sometimes I can see additional function sequences being entered, presumably from the "stuck" game keys

I then manually downgraded the firmware to the new q2d08a.rom file, but left everything else the same, and can no longer reproduce the behavior.

Changed 7 years ago by rsmith

please try http://dev.laptop.org/~rsmith/q2067.rom and see if it fixes the problems.

Changed 7 years ago by mtd

Works like a dream. I haven't used it for any length of time but the problems were immediate and obvious before and I have tried to reproduce them in Web, Read, and Write, and cannot. It seems great. Thanks!

Changed 7 years ago by eeksock

Also confirmed fixed for me. Thanks rsmith!

Changed 7 years ago by kweidner

I've upgraded to q2d10 since the Wiki news mentioned that this bug was fixed in that release.

I've tested it, works with no problems so far. I checked all keys and found no sticky ones. (Only the arrow/space/erase keys have autorepeat, but I'm assuming that's intentional and I just hadn't noticed this before.)

Thanks Richard!

-Klaus

Changed 7 years ago by supersat

Q2D10 also fixes both problems for me. The keys seem less sticky in general (at least in the self-test), but perhaps I'm imagining things.

Changed 6 years ago by rsmith

  • status changed from new to closed
  • next_action set to never set
  • resolution set to fixed

Changed 6 years ago by gregorio

  • milestone deleted

Milestone Never Assigned deleted

Note: See TracTickets for help on using tickets.