Opened 7 years ago

Closed 7 years ago

#6123 closed defect (duplicate)

WEP key entry broken

Reported by: bert Owned by: marco
Priority: blocker Milestone: Update.1
Component: sugar Version:
Keywords: wireless Cc: yani, jg, gdesmott, carrano
Blocked By: Blocking:
Deployments affected: Action Needed:
Verified: no

Description

Joyride-1551: Connecting to my WEP-encrypted router with a new MP machine did present the key entry dialog, but did not connect, rather it showed the dialog again. I tried both passphrase and 128 bit hex. My old B4 at the same build connected fine without any dialog because it was connected previously. I moved networks.cfg from the B4 to the MP, rebooted, and it connected fine.

No logs of the failed attempts because apparently /var/log/messages is erased on boot and no copy kept.

The router is running DD-WRT v23 SP1 Final.

Change History (9)

comment:1 Changed 7 years ago by jg

  • Keywords Update.1? removed
  • Milestone changed from Never Assigned to Update.1
  • Priority changed from normal to blocker

Sometime over the last number of joyrides, WEP stopped working.

Whether this is a problem with Sugar, or NM, or the kernel, or wpa-supplicant isn't known.

We do note WPA works now.

Might be some fix for Sugar did so, but we have other suspicions,
see trac #5485:

On Sun, 2008-01-20 at 13:34 -0500, Jim Gettys wrote:
> Michailis, it would be wonderful if you, Ricardo, or Yani can bisect
> joyride builds to tell us which build WEP stopped working in: we can
> then see what changed from the change logs an know whether it is
> likely a kernel driver, network manager, wpa-supplication or sugar
> bug.  

WEP works fine if set up manually, but not when wpa_supplicant does
it.  In trac #5485 we are waiting for driver logs.

Would be useful if someone would take a working build and update 
_just_ the kernel to check if it's a driver change which triggered 
this, and then use git-bisect to check precisely which change.

We'll have to verify WEP again after finding/fixing the bug at the top of the UI stack, so I'm making sure we'll keep our eyes on it.

comment:2 Changed 7 years ago by marco

  • Owner changed from marco to rwh

Reinier, can you have a look please? I'm busy with the shell redesign work until Friday...

comment:3 Changed 7 years ago by kimquirk

  • Cc yani jg added
  • Component changed from sugar to wireless
  • Keywords wireless added
  • Owner changed from rwh to dwmw2

I have tried this on Update.1-690 and cannot connect to my WEP at home (which has connected to almost every build I've ever tried). Dialog box keeps coming up even after entering a valid hex key.

I rebooted, but it still won't connect. Assigning to woodhouse since he has been playing with the driver, and changing component to wireless -- please reassign appropriately. I believe both WPA and WEP are broken in this build.

comment:4 Changed 7 years ago by kimquirk

  • Component changed from wireless to sugar
  • Owner changed from dwmw2 to marco

With some more testing on build 690... I noticed that I could not connect to WEP from a cleaninstall machine; but I can from an upgraded machine. I noticed that my entering a WEP key did not create a new entry in the /home/olpc/.sugar/default/nm/network.config file.

But if I manually create the entry in this file; then reboot, it will find and connect to my WEP AP.

I also tried turning off security and connecting to WEP - but it didn't help.

Does that mean it is a sugar bug?

comment:5 Changed 7 years ago by gdesmott

  • Cc gdesmott added

comment:6 Changed 7 years ago by carrano

  • Cc carrano added

This ticket seems either:

or

  • The original description points to #6182 (which was an UI issue - now fixed)

comment:7 Changed 7 years ago by marco

I can confirm that manually copying networks.cfg (generated on 656) makes it work. Though if I click on the mesh view icon again to reconnect, it fails.

It seem likely that this is a duplicate of #5485. I think we should wait that one to be fixed and then test again to see if there is any issue in the UI code.

comment:8 Changed 7 years ago by chihyu

Tested at 1cc on a MP machine with clean installed update.1 690, q2d10.

  • Machine powers up after clean installation to build 690 and then connects to mesh network.
  • Click on the "roofnet" AP and enter the password; machine connects to "roofnet".
  • Click on the "media lab 802.11" AP; machine connects to "media lab 802.11".
  • Click on the "roofnet" AP again; machine keeps prompting for password. Machine still fails to connect, even when the password has been entered more than 3 times. (The prompt for the password will eventually disappear. The machine will then connect to mesh network or not connect to any AP.)

There are three ways to reconnect to "roofnet":

  1. Click on the "media lab 802.11" AP. After machine connects to "media lab 802.11", click on the "roofnet" AP again.
  2. If that fails, click on one of the 3 mesh network APs. After machine connects to the mesh network, click on the "roofnet" AP again.
  3. If that also fails, edit out the [roofnet] section of /home/olpc/.sugar/default/nm/networks.cfg. The file does NOT have to be deleted. Then go back to sugar view and click on the "roofnet" AP again -- the machine should connect to "roofnet" now, withOUT re-entering the password. (Connecting to "roofnet" also creates a new [roofnet] section in networks.cfg.)

comment:9 Changed 7 years ago by marco

  • Resolution set to duplicate
  • Status changed from new to closed

Works for me now that #5485 is fixed, so I think it's actually a dup.

Note: See TracTickets for help on using tickets.