Opened 7 years ago

Closed 7 years ago

#6127 closed defect (fixed)

browse can't register handler

Reported by: erikos Owned by: erikos
Priority: high Milestone: Not Triaged
Component: browse-activity Version:
Keywords: relnote? Cc:
Blocked By: Blocking:
Deployments affected: Action Needed:
Verified: no

Description

  • open browse (A)
  • open another browse leaving A running (B)
  • close B
  • resume B (A is still running)
  • B is flashing and will crash

Attachments (1)

web_a_register.log (4.1 KB) - added by erikos 7 years ago.
browse register error

Download all attachments as: .zip

Change History (9)

Changed 7 years ago by erikos

browse register error

comment:1 Changed 7 years ago by marco

  • Milestone changed from Never Assigned to Update.1

comment:2 Changed 7 years ago by marco

  • Priority changed from normal to high

comment:3 Changed 7 years ago by marco

  • Milestone changed from Update.1 to Retriage, Please!

comment:4 Changed 7 years ago by erikos

The issue is that we need to releases the dbus object when we close the activity. If not does hurt us in the SingleProcess cases like browse.

Pushed fix to git sugar master.
http://dev.laptop.org/git?p=sugar;a=commitdiff;h=12869d0152595a4b32bb53617922adc1512dde53

comment:5 Changed 7 years ago by erikos

  • Keywords relnote? added

Sadly, due to Update.1 misunderstandings this simple fix never made it into a build - 702 has this error.

Effect: Can be best described with a use case.

open browse (A) - open another browse leaving A running (B) - close B - resume B (A is still running) - B is flashing and will crash

comment:6 Changed 7 years ago by Rmyers

This defect has 6289 listed as a duplicate. So I _think_ that this may be what I'm seeing. On trying to open Browse or NewsReader in 699. Activities fail with a message about not being able to create directory ~/.gnome2. (this is mentioned in #6289). I've gotten Browse to open by manually creating the requested directories. NewsReader keeps on incrementing the '10000' user number each time I try to open it.

If this is not what this defect is about, please let me know so I can create a new ticket.

comment:7 Changed 7 years ago by erikos

The missing ~/.gnome2 does not cause any problems, but we should fix it once because the question came up different times already. The fix described in #6127 did not make it into an update.1 build so likely you see what I described in #6127.

Did you turn debug logging on to see if you have any other errors that actually cause Browse not to start?

http://wiki.laptop.org/go/Attaching_Sugar_Logs_to_Tickets

Thanks

comment:8 Changed 7 years ago by erikos

  • Resolution set to fixed
  • Status changed from new to closed

This is in master and will therefore be in the august release.

Note: See TracTickets for help on using tickets.