Ticket #6166 (closed defect: invalid)

Opened 6 years ago

Last modified 6 years ago

local pdf download doesn't alert on download, doesn't launch Read.

Reported by: sj Owned by: erikos
Priority: normal Milestone: Update.1
Component: browse-activity Version:
Keywords: read Cc: chihyu
Action Needed: never set Verified: no
Deployments affected: Blocked By:
Blocking:

Description

687, spanish machine.

Clicking on Phyla.pdf to download it from the local biology collection causes it to be silently downloaded to the datastore, with a journal entry, but didn't provide any alert. Duplicated behavior twice on this machine.

Attachments

cron (393 bytes) - added by chihyu 6 years ago.
dmesg (25.8 kB) - added by chihyu 6 years ago.
messages (2.8 kB) - added by chihyu 6 years ago.
org.laptop.WebActivity-1.log (220 bytes) - added by chihyu 6 years ago.
rainbow (10.6 kB) - added by chihyu 6 years ago.
secure (348 bytes) - added by chihyu 6 years ago.
shell.log (1.4 kB) - added by chihyu 6 years ago.
Xorg.0.log (33.2 kB) - added by chihyu 6 years ago.

Change History

  Changed 6 years ago by marco

  • milestone changed from Never Assigned to Update.1

  Changed 6 years ago by erikos

Just tested 687 and it looks like this is not something that is due to that specific build - I had the alert just fine. I had something like this once - when I did upgrades. Maybe another candidate for an upgarde issue. sj maybe you remember if you upgraded and if the number would be helpful as well, thanks?

follow-up: ↓ 5   Changed 6 years ago by marco

Can you reproduce this consistently?

  Changed 6 years ago by marco

Also, debug logs would be useful here.

http://wiki.laptop.org/go/Attaching_Sugar_Logs_to_Tickets

in reply to: ↑ 3   Changed 6 years ago by chihyu

Tested on update.1 690, and the same issue remains:

There was a first prompt indicating the file was going to be downloaded; there was a second prompt indicating download completion. The Read activity should have launched right afterwards, but I could not read the pdf file unless I manually clicked on the Journal entry of the download history.

Replying to marco:

Can you reproduce this consistently?

Changed 6 years ago by chihyu

  • attachment cron added

Changed 6 years ago by chihyu

Changed 6 years ago by chihyu

Changed 6 years ago by chihyu

Changed 6 years ago by chihyu

Changed 6 years ago by chihyu

Changed 6 years ago by chihyu

Changed 6 years ago by chihyu

follow-up: ↓ 8   Changed 6 years ago by erikos

You download a pdf (local or over the network), the alert indicates that the download has started, a second indicates that the download has finished. You can use the [Open] button in the second alert or the journal entry to resume this object. Does only resuming from the journal works for you? The read activity does not auto launch if it is that what you mean.

  Changed 6 years ago by erikos

Actually the [Open] button does open the object in the journal and you can open it with read from there.

I thought in sj's post he could not see the alert at all.

in reply to: ↑ 6   Changed 6 years ago by chihyu

I did click on the "Open" button in the second alert, but the pdf file was not opened by any activity.

The only way I could read the pdf file was to manually locate the journal entry and click on it.

Replying to erikos:

You download a pdf (local or over the network), the alert indicates that the download has started, a second indicates that the download has finished. You can use the [Open] button in the second alert or the journal entry to resume this object. Does only resuming from the journal works for you? The read activity does not auto launch if it is that what you mean.

  Changed 6 years ago by erikos

  • status changed from new to closed
  • resolution set to invalid

I did click on the "Open" button in the second alert, but the pdf file was not opened by any activity.

Maybe i explained badly. When you hit [open] in the second alert the detail view of this entry will be displayed (Journal). You can than resume from there. This changed from earlier behavior where we resumed directly.

If it is another bug please reopen and provide browse logs.

follow-up: ↓ 11   Changed 6 years ago by marco

erikos, if I read chihyu comment correctly, the entry was not displayed in the journal as expected. (she had to manually locate the entry in the journal)

in reply to: ↑ 10   Changed 6 years ago by chihyu

I apologize for being unclear. What I meant by "manually locate the journal entry" is:

  • Go to Journal
  • Locate the entry that reads File Phyla-EOW.pdf from file:///usr/share/activities/biology/Phyla-EOW.pdf.
  • Click on this entry

If I do not click on this entry, Read will not launch. I was told that Read should open the pdf file as soon as I click the "OK" button from the second prompt.

If it was designed this way (user has to click on the journal entry with such a long title, in order to read the pdf file), then this is not a bug. We should leave it closed.

Replying to marco:

erikos, if I read chihyu comment correctly, the entry was not displayed in the journal as expected. (she had to manually locate the entry in the journal)

  Changed 6 years ago by erikos

I updated the browse test page with instructions to test downloads, I hope this makes it a bit clearer now ( http://wiki.laptop.org/go/Tests/Browse ).

  Changed 6 years ago by erikos

Btw: I think that the download was not alerted was this bug (multiple instances open and the alert gets displayed in the wrong instance): #5822

  Changed 6 years ago by frances

  • next_action set to never set

I found if you chose "Show In Journal" then you can access it from the intermediate page.

Note: See TracTickets for help on using tickets.