Ticket #6170 (closed defect: fixed)

Opened 7 years ago

Last modified 6 years ago

shared write activity crash on joined machine when changing current active activity

Reported by: erikos Owned by: ApprovalForUpdate
Priority: blocker Milestone:
Component: write-activity (abiword) Version:
Keywords: Cc: marco, tomeu, erikos
Action Needed: Verified: no
Deployments affected: Blocked By:
Blocking:

Description

Reproduce:

A: shares write B: joins and switches to another activity (changes current active activity)

Tested on 687 and 682 with gabble and salut.

Logs are here: http://olpc.scheffers.net/olpc/browse.tcl?p=20080123-215041-85.178.199.253

There is nothing in the write logs but i collected the attached one from another try when debug was not enabled.

Attachments

org.laptop.AbiWordActivity-1.log (487 bytes) - added by erikos 7 years ago.
write log member change
org.laptop.AbiWordActivity-1.2.log (7.6 kB) - added by erikos 7 years ago.
Keep as plain text in joined Write

Change History

Changed 7 years ago by erikos

write log member change

Changed 7 years ago by erikos

Oups the attached one org.laptop.AbiWordActivity-1.log was not the right one. But i hope it can reproduce in the way i described.

Changed 7 years ago by marco

  • milestone changed from Never Assigned to Update.1

Changed 7 years ago by erikos

  • cc marco, tomeu added
  • summary changed from sharing: write crash on member change to shared write activity crash on joined machine when changing current active activity

The log gives a hint that setting the active activity does fail. The error handler for service.SetActive gets called.

sugar/src/model/homemodel.py:210:        logging.error("set_active() failed: %s" % err)

I could only reproduce this for a shared write activity so far. Reproduced on 691 as well.

Changed 7 years ago by erikos

Test a) Change active activity The call SetActive(False) for Write times out 'Message did not receive a reply'. Write crashes.

Test b) Keep as plain text The log is attached. Write crashes.

In both cases sharing did work fine before the action.

The test above shows that write will not only crash when changing the current active activity.

Changed 7 years ago by erikos

Keep as plain text in joined Write

Changed 7 years ago by erikos

I tested with a few other activities (browse, record, memorize, chat, calculate) and it only happens in write. gabble and salut as well produce the same behavior.

Attaching strace to the process on the machine which joined it looks like Write segfaulted.

Changed 7 years ago by tomeu

Stack trace:

Program received signal SIGSEGV, Segmentation fault.
0xb4621dc8 in PD_Document::saveAs (this=0x8a48800, output=0x8eadf08, ieft=10, cpy=true, expProps=0x0) at pd_Document.cpp:608
608             return _saveAs(output, ieft, cpy, expProps);
(gdb) bt full
#0  0xb4621dc8 in PD_Document::saveAs (this=0x8a48800, output=0x8eadf08, ieft=10, cpy=true, expProps=0x0)
    at pd_Document.cpp:608
No locals.
#1  0xb43468de in abi_widget_get_content (w=0x8377298, extension_or_mimetype=0x84abe94 ".txt", exp_props=0x0, 
    iLength=0xbfa14200) at abiwidget.cpp:1201
        ieft = 10
        sink = (GsfOutputMemory *) 0x8eadf08
        result = -47600495
        size = 139141824
        ibytes = (const guint8 *) 0x8c0f35c "\001"
        szOut = (gchar *) 0x1a141f4 <Address 0x1a141f4 out of bounds>
#2  0xb48efe4f in _wrap_abi_widget_get_content (self=0x8a87144, args=0xb7d1602c, kwargs=0x8c0f35c) at ./pyabiword.override:54
        bytes = <value optimized out>
        extension_or_mimetype = (gchar *) 0x84abe94 ".txt"
        exp_props = (gchar *) 0x0
        iLength = 146862940
        kwlist = {0xb48f1e0e "extension_or_mimetype", 0xb48f1e24 "exp_props", 0x0}

Changed 7 years ago by erikos

  • priority changed from high to blocker

#5524 stated that this was an issue on 653 already. Make this a blocker since #5524 was a blocker.

Changed 7 years ago by tomeu

Changed 6 years ago by cscott

Patch has been committed upstream. How do we turn the crank to get a new version of the write activity? (Or is there an abiword rpm that needs to be updated?)

Changed 6 years ago by marco

We need uwog to build rpms.

Changed 6 years ago by uwog

I'm working on getting 2.6.0 out tomorrow or this weekend. The new OLPC rpms will follow immediately after that.

Changed 6 years ago by cscott

uwog: status? we'd like to get update.1 out soonish.

Changed 6 years ago by uwog

Tomorrow, would that do cscott?

Changed 6 years ago by Blaketh

  • keywords release? added

Changed 6 years ago by uwog

  • owner changed from uwog to ApprovalForUpdate
  • milestone deleted

Uploaded a new rpm to dev.laptop.org.

Changed 6 years ago by erikos

  • cc erikos added

I tested the rpm in joyride-1796 as working.

I will verify in update.1 as well.

@uwog: the process should be to indicate that you tested in joyride and name who will verify the fix then: http://wiki.laptop.org/go/Update.1_process I know it changed a lot of times :)

Changed 6 years ago by bemasc

Still broken in Update.1-702.

Changed 6 years ago by erikos

Yup since the libabiword rpm never made it in 702. I hope we get another build.

Changed 6 years ago by erikos

  • keywords release? removed
  • status changed from new to closed
  • resolution set to fixed

Tested as fixed in 703.

Note: See TracTickets for help on using tickets.