Ticket #6187 (new defect)

Opened 7 years ago

Last modified 7 years ago

Record activity is frozen after lauching Write

Reported by: chihyu Owned by: jg
Priority: high Milestone: 8.2.0 (was Update.2)
Component: distro Version:
Keywords: release? Cc: tomeu, rsmith, cjb, mstone
Action Needed: Verified: no
Deployments affected: Blocked By:
Blocking:

Description

Tested with 2 MP machines with build 687, firmware q2d09.

reproduction steps

  • Launch Write; type something; close Write.
  • Launch Record; leave the machine unattended (untouched) for about 5 minutes.

The Record window should display whatever the camera "sees" in real time, but now it only shows a still image (seen 5 minutes ago).

The power indicator LED is on (non-flashing), but the machine does not respond to any key press or mouse movement. Closing the lid or pressing the power button does not bring the machine to sleep mode (power indicator LED remains on) or to resolve the issue.

Attachments

cron Download (389 bytes) - added by chihyu 7 years ago.
dmesg Download (24.8 KB) - added by chihyu 7 years ago.
messages Download (46.3 KB) - added by chihyu 7 years ago.
org.laptop.RecordActivity-1.log Download (255 bytes) - added by chihyu 7 years ago.
rainbow Download (62 bytes) - added by chihyu 7 years ago.
secure Download (0.9 KB) - added by chihyu 7 years ago.
shell.log Download (11.3 KB) - added by chihyu 7 years ago.
Xorg.0.log Download (31.8 KB) - added by chihyu 7 years ago.
cron.2 Download (0.7 KB) - added by chihyu 7 years ago.
build 690
dmesg.2 Download (28.4 KB) - added by chihyu 7 years ago.
build 690
messages.2 Download (81.5 KB) - added by chihyu 7 years ago.
build 690
org.laptop.AbiWordActivity-1.log Download (492 bytes) - added by chihyu 7 years ago.
build 690
org.laptop.RecordActivity-1.3.log Download (226 bytes) - added by chihyu 7 years ago.
build 690
org.laptop.RecordActivity-1.2.log Download (226 bytes) - added by chihyu 7 years ago.
build 690
rainbow.2 Download (4.2 KB) - added by chihyu 7 years ago.
build 690
secure.2 Download (1.3 KB) - added by chihyu 7 years ago.
build 690
shell.2.log Download (503 bytes) - added by chihyu 7 years ago.
build 690
Xorg.0.2.log Download (31.8 KB) - added by chihyu 7 years ago.
build 690

Change History

Changed 7 years ago by chihyu

  • attachment cron Download added

Changed 7 years ago by chihyu

Changed 7 years ago by chihyu

Changed 7 years ago by chihyu

Changed 7 years ago by chihyu

Changed 7 years ago by chihyu

Changed 7 years ago by chihyu

Changed 7 years ago by chihyu

  Changed 7 years ago by marco

  • milestone changed from Never Assigned to Update.1

follow-up: ↓ 3   Changed 7 years ago by tomeu

  • cc tomeu added

I find strange that this happens only after having launched and closed Write.

Perhaps has something to do with suspend?

chihyu, are you sure that launching Write before has something to do with this problem?

Also, I've been trying to reproduce with joyride-1617 and failed. The XO enters in suspension after 30 seconds (power led blinks). It also comes out from suspend successfully.

in reply to: ↑ 2   Changed 7 years ago by chihyu

Replying to tomeu:

I find strange that this happens only after having launched and closed Write. Perhaps has something to do with suspend? chihyu, are you sure that launching Write before has something to do with this problem?

In my previous tests with build 687, Record worked fine if it was the first activity launched after the machine powered up. If Write was launched before Record, the problem described in my first post would occur.

Just tested with build 690, firmware q2d10a:

  • Power up the machine.
  • Launch Write; type something; close Write.
  • Launch Record; leave the machine unattended (untouched) for 3-5 minutes.

The frame (which should be toggled by the key at the upper right corner) automatically shows up after the machine is left untouched for a short while (3 minutes). The entire screen flashes a couple of times (frame quickly disappears and reappears?) after the frame shows up.

The machine then enters in suspension (power light blinking). During suspension, the Record activity shows a still image rather than what the camera sees in real time. And the machine will come out from suspension every 10~15 seconds. When the machine is not in suspension, the Record activity shows what the camera sees in real time.

Changed 7 years ago by chihyu

build 690

Changed 7 years ago by chihyu

build 690

Changed 7 years ago by chihyu

build 690

Changed 7 years ago by chihyu

build 690

Changed 7 years ago by chihyu

build 690

Changed 7 years ago by chihyu

build 690

Changed 7 years ago by chihyu

build 690

Changed 7 years ago by chihyu

build 690

Changed 7 years ago by chihyu

build 690

  Changed 7 years ago by tomeu

  • cc rsmith, cjb added

All this seems very strange to me.

The only explanation I can think of is that the touchpad is emitting events as if the pointer was in some corner (0,0?). That would make the frame appear and would avoid the laptop entering in suspension.

Perhaps you could show this behavior to Richard or Chris and see if them can find some explanation to this?

  Changed 7 years ago by mstone

  • cc mstone added
  • keywords release? added
Note: See TracTickets for help on using tickets.