Ticket #6249 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Battery not charging after installing Update.1 690!

Reported by: garycmartin Owned by: rsmith
Priority: blocker Milestone: Update.1
Component: embedded controller Version: Development build as of this date
Keywords: Cc:
Action Needed: Verified: no
Deployments affected: Blocked By:
Blocking:

Description

No battery led charging indicator when plugged in, though I am now getting the red indicator. Worried I'm about to turn this B4 xo into a cute brick if I can't get it to accept power very soon :-( Been working fine up until moving to 690 last night. Firmware is Q2D10, but have been using that for a number of days under other os builds without issue. Initially after first installing 690 it seemed to be charging and reporting fine on the home screen, but this seems to have kicked in after a reboot or shutdown.

Change History

Changed 6 years ago by garycmartin

OK. Damn. It now looks like I have a os690 B4 brick :-( I tried to quickly copy-nand back to build 656 in the hopes that it would allow the xo to charge again, but before I could get get to that point the laptop powered off and will now not power back on (brief LED flash then off again). Can someone recommend how to power the laptop through some other means (I'm handy with a screwdriver and DVM)?

Quite surprised that the xo (B4) is able to disable power input, and even more so that you can't run an xo with no battery in place and just run it temporally off the mains when there is a battery problem. Seems quite an omission given that batteries quality can vary so much, unless I'm missing something obvious. Any suggestions much appreciated (help)!

Changed 6 years ago by cjb

  • owner changed from cjb to rsmith
  • priority changed from high to blocker
  • component changed from power manager (OHM) to embedded controller
  • milestone changed from Never Assigned to Update.1

Changed 6 years ago by garycmartin

  • status changed from new to closed
  • resolution set to fixed

After taking my own advice and setting to with a DVM I found an embarrassingly simple issue not related to the xo. I'm running this in the UK and a travel adapter is the only thing I can find that will fit the shape of the xo green charger and convert to a UK plug. After testing the xo charger and finding no voltage, I had a closer look at the travel adapter and found it was a fused device - and only rated to 1Amp... Problem solved, the xo charger is rated to 1.2Amps so it must have bumped over by coincidence with me updating to Update.1 690. Now replaced with a higher rated fuse and all is well again with the world. Apologies for not spotting this sooner.

Note: See TracTickets for help on using tickets.