Opened 7 years ago

Last modified 2 years ago

#6308 new defect

browse activity does not release sound device

Reported by: erikos Owned by: erikos
Priority: low Milestone: 9.1.0-cancelled
Component: browse-activity Version:
Keywords: relnote Cc: humitos
Blocked By: Blocking:
Deployments affected: Action Needed: diagnose
Verified: no

Description

Reproduce:

  • play a file (e.g recorded with Record) in browse
  • leave the browse activity open
  • start record (no camera input can be seen, no recording done etc...)
  • open memorize, try game drumgit (same here) ...

Logs are attached. Tested on 690 and 1621 and 653, so this was already broken in ship.2

Attachments (2)

org.laptop.Memorize-1.log (9.3 KB) - added by erikos 7 years ago.
memorize not able to access sound device
org.laptop.RecordActivity-1.log (3.3 KB) - added by erikos 7 years ago.
record not able to access sound device

Download all attachments as: .zip

Change History (9)

Changed 7 years ago by erikos

memorize not able to access sound device

Changed 7 years ago by erikos

record not able to access sound device

comment:1 Changed 7 years ago by erikos

  • Keywords relnote added; marco tomeu removed

If you played an audio or video file with Browse and leave the activity open you will not be able to use any other activity that plays sound or video (e.g. Record, Memorize) since the sound device is already in use and unlike other activities like Memorize the sound device is not released when the activity is not in focus.

Effect: In Record the live display will be black. Once you close Browse and switch back to Record, the Record activity will work like expected again.

comment:2 Changed 7 years ago by erikos

  • Keywords relnote? added; relnote removed

comment:3 Changed 6 years ago by gregorio

  • Milestone Never Assigned deleted

Milestone Never Assigned deleted

comment:4 Changed 6 years ago by marco

  • Action Needed set to diagnose
  • Milestone set to 8.2.0 (was Update.2)

comment:5 Changed 6 years ago by marco

  • Milestone changed from 8.2.0 (was Update.2) to 9.1.0

comment:6 Changed 6 years ago by gregorio

  • Keywords relnote added; relnote? removed

added to the release notes.

Thanks,

Greg S

comment:7 Changed 2 years ago by humitos

  • Cc humitos added
  • Priority changed from high to low

I tested this on XO 1.75 12.1.0 build 20 with Browse 140 and Record 96.

  1. Open Browse
  2. Go to and .mp3 file
  3. Open Record

I can see the image of the webcam while the .mp3 coming from Browse is still playing. I can take pictures and I can record some audio but when I switch to Browse again and then again to Record, the audio stops and I can't have both working at the same time anymore. When I have focus on Record I can take pictures and so, but the audio is not playing and when I have focus on Browse the audio continues playing.

Note: See TracTickets for help on using tickets.