Opened 7 years ago

Last modified 7 years ago

#6370 new defect

WPA doesn't reconnect after olpc-update to 691

Reported by: kimquirk Owned by: erikos
Priority: high Milestone: 8.2.0 (was Update.2)
Component: network manager Version:
Keywords: Cc:
Blocked By: Blocking:
Deployments affected: Action Needed:
Verified: no

Description

Build 690, with network.cfg file already in existance; upgrade to 691, and I can no longer connect to WPA. I continue to get the pop up to enter the WPA password.

Remove the /home/olpc/.sugar/default/nm/network.cfg file; reboot; then I can connect.

I don't know who to give this to; but if it is the case that we need to remove that file as part of an upgrade (for short term, perhaps), then I am currently assigning to the upgrade utility.

Attachments (1)

dmesg-eth0-prb.txt (122.7 KB) - added by garyo 7 years ago.
dmesg output with libertas debug enabled.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 7 years ago by cscott

  • Component changed from upgrade utility to network manager
  • Owner changed from cscott to erikos

Should be assigned to NetworkManager, at least until we understand the exact issue. If post-install hooks are needed, they would be done in olpc-configure in olpc-utils in bernie's package.

comment:2 Changed 7 years ago by erikos

Hmm not sure I can reproduce the issue described. I did a clean install of 690 and connected to my AP which uses WPA2 (network.cfg got created). I than updated to 691 and rebooted. I was automatically connected to my AP just fine without removing the config file.

Will make some more tests.

comment:3 Changed 7 years ago by erikos

Tested the steps I described above as well for WPA and it worked fine. The case where I had to remove the .cfg file was when I switched encryption of the AP - but I think this is known.

Example:

  • xo is connected to AP (using WPA2)
  • change the AP to use WPA
  • xo will not be connected to AP anymore
  • clicking on the AP icon(and entering the key), restarting sugar and NM or rebooting does not help
  • i need to remove the .cfg file to be able to connect again

comment:4 Changed 7 years ago by garyo

I can only connect to WPA about 10% of the time with recent builds. I just updated to latest Joyride (joyride-1697) to see if it would help, but it's just the same. I've attached the dmesg output with libertas debugging turned on per instructions from Ricardo Carrano.

Stats: G1G1 XO, joyride-1697 (copy-nand install). Deleted networks.cfg first.
AP: Linksys WAP54G, stock firmware, WPA1.

Changed 7 years ago by garyo

dmesg output with libertas debug enabled.

comment:5 Changed 7 years ago by garyo

one more thing: the AP (WAP54G) has "WPA-Personal" (not WPA2), AES encryption, not TKIP.

comment:6 Changed 7 years ago by bemasc

I can confirm this behavior, running joyride-1643. That was a clean install, using copy-nand, so I don't think this is related to olpc-update. As kimquirk stated, removing network.cfg fixed it.

Note: See TracTickets for help on using tickets.