Opened 7 years ago

Closed 3 years ago

#6537 closed defect (fixed)

Sharing problems with Salut

Reported by: gdesmott Owned by: morgs
Priority: normal Milestone: 11.2.0-M3
Component: read-activity Version:
Keywords: release? cjbfor9.1.0 Cc: Collabora, cjb
Blocked By: Blocking:
Deployments affected: Action Needed: test in build
Verified: no

Description

On #6483 was discussed some sharing issues with Read and Salut.

I did lot of tests and sharing almost never works with Salut on XO's (but works pretty well with sugar-jhbuild with my stream tubes fix (see #6483)).
Though disable Read's suspend policy (by creating this file /etc/inhibit-ebook-sleep) really improve results.
So I think something goes wrong in Read's suspend code.

Would be cool if a Read developper could explain us how it's supposed to manage suspend.

Change History (15)

comment:1 Changed 7 years ago by gdesmott

See #6538 for another suspend problem with Read.

comment:2 Changed 7 years ago by morgs

  • Cc Collabora added; collabora removed

comment:3 Changed 7 years ago by bemasc

After looking at the code, the problem is that Read suspends so aggressively that it will not even receive the "Join" notification when someone else joins the activity and requests the file. The sleep code may even interrupt the transfer. This is a major bug in Read. Fundamentally, Read must never suspend once it is shared, because it must receive multicast notifications in order for sharing to work.

comment:4 Changed 7 years ago by gdesmott

Well, the real problem is in the wifi firmware which doesn't wake up when receiving multicast packets.

comment:5 Changed 7 years ago by gnu

You can make the wifi firmware wake up on multicast packets (that this laptop is interested in) by doing this command: "ethtool -s eth0 wol um". The "u" in the last argument is unicast, "m" is multicast, (you can also add "b" to wake on broadcasts, though I don't recommend it). I suggest testing with this change and seeing if it is really the only problem, or whether we have other problems in Read or sharing that should also be addressed.

comment:6 Changed 7 years ago by cjb

We wouldn't stay asleep for very long if we turned on wake on multicast, though, which would probably remove the point of these suspends. I agree it's still an interesting test.

comment:7 Changed 7 years ago by gdesmott

I did some tests and multicast wake *does* improve things. Sharing was working fine without /etc/inhibit-ebook-sleep.

comment:8 Changed 7 years ago by Blaketh

  • Keywords release? added

comment:9 Changed 6 years ago by gregorio

  • Milestone Never Assigned deleted

Milestone Never Assigned deleted

comment:10 Changed 6 years ago by marco

  • Action Needed set to diagnose
  • Milestone set to 8.2.0 (was Update.2)

comment:11 Changed 6 years ago by morgs

  • Owner changed from rwh to morgs

comment:12 Changed 6 years ago by morgs

  • Milestone changed from 8.2.0 (was Update.2) to 8.2.1

comment:13 Changed 6 years ago by mstone-xmlrpc

  • Keywords cjbfor9.1.0 added
  • Milestone changed from 8.2.1 to 9.1.0

Pushing out to 9.1.0, per edmcnierney's request.

comment:14 Changed 3 years ago by godiard

  • Action Needed changed from diagnose to test in build
  • Milestone changed from 9.1.0-cancelled to 11.2.0-M3

Sharing is already working and Read inhibit suspend when needed.

comment:15 Changed 3 years ago by dsd

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.