Ticket #6707 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Chat stops sharing after 30-60 minutes

Reported by: kimquirk Owned by: Collabora
Priority: high Milestone:
Component: telepathy-salut Version:
Keywords: release? Cc:
Action Needed: Verified: no
Deployments affected: Blocked By:
Blocking:

Description

Build 699, signed; OFW q2d13

I have 4 laptops with this build, connected to school server mesh 6. They can get out on the internet.

I started chat and record on two different laptops and shared them both with the neighborhood.

I made sure that both activities were shared properly and were seen on all other laptops. I took pictures from each laptop; and I chatted from each laptop and made sure all the other laptops saw all the words and pictures.

Less than an hour later, (machines had gone to screen saver, but not to sleep or suspend), I tried chatting again and one of the laptops didn't receive messages from others and none of its messages were received by others.

I tried a bunch more chats and now there are a number of missing messages.

Record continues to work properly; sharing photos across all 4 laptops.

I used 'olpc-netstatus' on all machines and it says Salut is running.

The presence log and chat log don't say anything interesting. (tell me if I need to turn something else on or get logs a different way).

Change History

Changed 6 years ago by gdesmott

Could be related to #6575

Changed 6 years ago by gdesmott

We'll need Salut log with GIBBER_DEBUG=all enabled (see http://wiki.laptop.org/go/Telepathy-debug for details).

Changed 6 years ago by gdesmott

Please retest using telepathy-salut-0.2.3-1.olpc2 as #6575 should be fixed with this version.

Changed 6 years ago by morgs

See #6728 for the new salut version, should be in the next joyride.

Changed 6 years ago by Blaketh

  • keywords release? added

Changed 6 years ago by morgs

This is in Update.1-701. Please test, close and mark as verified if it's fixed.

Changed 6 years ago by erikos

Just tested again after an hour and I could send messages between 3 machines running 703 and sharing using Salut. I will have a look again after another hour before closing.

Changed 6 years ago by erikos

  • status changed from new to closed
  • resolution set to fixed

All good as well after 2 hours.

Changed 6 years ago by gregorio

  • milestone deleted

Milestone Never Assigned deleted

Note: See TracTickets for help on using tickets.