Opened 7 years ago

Closed 5 years ago

#6758 closed defect (invalid)

Record fails after update to candidate-767 (says Journal is Full)

Reported by: chm Owned by: erikb
Priority: high Milestone: 8.2.0 (was Update.2)
Component: camera-activity Version: Development build as of this date
Keywords: camera, record, journal full, customization key, release? Cc: mstone, cjb, olpc-dev@…
Blocked By: Blocking:
Deployments affected: Action Needed: never set
Verified: no

Description

I used olpc-update to load update.1-702 on my G1G1
laptop and then used the Customization Key version 1
to load the *.xo bundle files. Not all were installed
and I manually installed the remainder.

Using Record, I tried to take a picture. This failed
with a message the the Journal was full. I've never
had this problem before and df . says I still have over
180MiB flash left. It is possible that the customization
process and the manual installs left a bunch of large
objects (duplicates) in the datastore.

Change History (11)

comment:1 Changed 7 years ago by mstone

  • Component changed from distro to camera-activity
  • Keywords release? added
  • Owner changed from jg to erikb
  • Priority changed from normal to high

chm: If you can reproduce this result, please run "olpc-netlog" from the console and attach the resulting tarball to this ticket.

Also, what version of Record were you trying?

eric: please suggest an explanation for why this message might have been generated?

(I don't really believe that this is a Record-specific problem, but I'm assigning the ticket to you for initial investigation. Let me know quickly if you are unable to reproduce the issue.)

comment:2 Changed 7 years ago by mstone

  • Cc mstone cjb added

comment:3 Changed 7 years ago by erikb

  • Cc olpc-dev@… added

comment:4 Changed 7 years ago by chm

I am unable to reproduce this since I had to re-olpc-update the XO
to regain use of the system...my apologies for that. I did not
wait on the re-update since it looked like the hang in the Customization-1
was the culprit---I had to reboot to get the system running again.

Whatever happened caused the Web activity to fail to start
and the Opera activity as well. The "Journal full problem"
appeared to affect the Activity start process.

I don't remember the Record version but since I used the same
in the re-update last night, I'll post that info this evening
when I get to my XO again.

Specifically, in the Record activity, on each of the 3 tabs (Photo,
Video, Audio) there was a sort of circle with an X in it icon instead
of the record/snap button and the words "Journal is full" next to it.

comment:5 Changed 7 years ago by HoboPrimate

I also olpc-updated to 702 and Record gave this error message, when I had 100+ megabytes free. I tested Measure and TamTamJam during this, and they launched and worked fine . After deleting some 50 objects from the journal (many activities, but also a lot of pdfs and downloaded activity bundles), Record now works. Sorry, I forgot to grab the logs before "fixing" it.

comment:6 Changed 6 years ago by mash

  • Summary changed from Record fails after upgrade to update.1-702 (says Journal is Full) to Record fails after update to 703 (says Journal is Full)

I updated to 703 and now I am having the same problem in Record. ("Your Journal is full" and the shutter button is an 'X'). I am not having the problem in other programs, including Measure.

comment:7 in reply to: ↑ description Changed 6 years ago by turboroe

  • Keywords camera record added

I have just tested build 703 on 2 of the Btest-2 and one Btest-4 I have here.
I did a clean update (copy-nand) on all of them. All using Firm Q2D16

On the B4 the camera worked fine.

On the first B2 I installed some activities, but on the /usr/share/activities directory.
They all worked fine, but the Camera had this "Your journal is full" problem
On the second B2 I installed only the Record activity, on the home/olpc/Activities directory. It worked, but still had this problem.

So on both B2´s I had this "Your journal is full" problem, exactly as described above, even with a clean nand and nothing in the Journal.

I took a look at the Record activity log and here´s what it said:

groupadd: group 10001 exists
Creating mailbox file: File exists

(sugar-activity:2141): libfnomevfs-WARNING : Unable to create ~/.gnome2 directory: Permission denied

(sugar-activity:2141): libfnomevfs-WARNING : gnome_vfs_init(): .gnome does not exist

comment:8 Changed 6 years ago by Udi

  • Action Needed set to never set
  • Version set to Development build as of this date

This is happening on my XO on joyride 2301.

See attached logs.

Udi

comment:9 Changed 6 years ago by skimla

  • Summary changed from Record fails after update to 703 (says Journal is Full) to Record fails after update to candidate-767 (says Journal is Full)

I just upgraded from build 656 to candidate-767 for 'Friends in testing' effort. I had a hiccup prior to upgrading and found out my olpc-update was old. Updated to 2.17, then the upgrade process worked (using usb upgrade process). I updated all activities and tried to run through the smoke test.

During the Record session, I'm also getting "Your Journal is full" albeit only having 53 journal entries, 77MB free. I deleted all of them and tried Record again, but the message is still there with the X icon. I tried rebooting and it did not help.

comment:10 Changed 6 years ago by cjb

This is expected.

Record checks for 20% of disk space left, so that's 200MB free; if you have less, it won't let you take photos. Maybe it should -- I think the check is mainly there for video, not photos.

comment:11 Changed 5 years ago by cjl

  • Resolution set to invalid
  • Status changed from new to closed

Closing as invalid, this is expected behavior as the last comment notes.

Note: See TracTickets for help on using tickets.