Ticket #6767 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Installation of library content on update.1-702

Reported by: mstone Owned by: sj
Priority: high Milestone: 8.2.0 (was Update.2)
Component: library Version:
Keywords: release? relnote? Cc: mstone
Action Needed: never set Verified: no
Deployments affected: Blocked By:
Blocking:

Description

While running the 1 Hour Smoke Test with update.1-702 on Spanish-language B4 Gary Martin reported that

the default Browse page for the local Library content broke after trying to do the tests for downloading additional library bundles.

Assigning to the library component for reproduction.

Change History

Changed 6 years ago by walter

try running /usr/share/library-common/make_index.py

It should be run after every bundle install, but this may not be in place yet in 702.

Changed 6 years ago by garycmartin

Thanks walter, yep I managed to get there. The glitch was revealed by some error output. After test downloading bible-en and biology v5, /usr/share/library-common/make_index.py would fail with an error. Just a simple typo in the source code that needs correcting:

File "/usr/share/library-common/make_index.py", line 192, in <module>

new_buddleactivity_start? = 'index.html'

NameError: name 'new_buddle' is not defined

Changing new_buddle to new_bundle and the index page is regenerating correctly for me again :-)

Changed 6 years ago by sj

This was a typo noted and patched (see #6680). It looks as though olpc-library-common-1-23.rpm and library-core-1-23 weren't being included properly -- There was apparently two source rpms named 1-23.

I'm making olpc-library-common-1-24.rpm and olpc-library-core-1-24.rpm with just this change; please include those in the next build.

Changed 6 years ago by sj

  • cc mako added

these are updated in my joyride directory on crank.

Changed 6 years ago by sj

  • cc mako removed

correction to the core package; please use olpc-library-common-1-24 and olpc-library-core-1-26. These were tested locally on spanish machines with multiple language settings.

(already noted on irc; just updating the ticket)

Changed 6 years ago by erikos

SJ I think it would make sense to follow the process http://wiki.laptop.org/go/Update.1_process and use the ticket (assign to ApprovalForUpdate after testing in joyride etc) for updates on the status.

It looks like this was mainly the reason why we hit this error again after filing #6680 already.

Changed 6 years ago by mstone

This was partly my fault for not following the procedure correctly; SJ and I were working together with dgilmore so I expedited the creation of 703 after having personally tested SJ's new rpms on a 702 machine.

Changed 6 years ago by mstone

It seems that olpc-utils' olpc-configure script is running make_index.py with LANG="C". Encountering bundles whose directory-names include non-ascii characters then produces broken library indices. Attached is a patch which I believe will avoid the issue; I'd like to consider it in an updated olpc-utils along with any changes we consider for #6185.

Changed 6 years ago by sj

  • status changed from new to closed
  • next_action set to never set
  • resolution set to fixed

has been fixed.

Note: See TracTickets for help on using tickets.