Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#6779 closed defect (fixed)

logview activity is doing heavy processing

Reported by: erikos Owned by: edsiper
Priority: high Milestone:
Component: log-activity Version:
Keywords: Cc:
Blocked By: Blocking:
Deployments affected: Action Needed:
Verified: no

Description

Updated from ship.2 (653) to update.1 (703). The Log activity is doing heavy processing (top states ~98%) when in use.

I moved the .sugar directory (and created a new one) and it was fine then. The logs did not show anything special.

This is still a broad analysis have to narrow this a bit with testing now.

Change History (3)

comment:1 Changed 7 years ago by erikos

  • Priority changed from normal to high

Ok I see what the issue is - when having the Record bug described in #6778 the log gets 131K big. An amount the logviewer does not seem to swallow.

We should think about how we can handle such cases better.

comment:2 Changed 7 years ago by wadeb

  • Resolution set to fixed
  • Status changed from new to closed

I created a 150k log file and ran the log viewer, it displayed the file and was not using any significant CPU. Reopen with steps to reproduce this if it still occurs.

comment:3 Changed 6 years ago by gregorio

  • Milestone Never Assigned deleted

Milestone Never Assigned deleted

Note: See TracTickets for help on using tickets.