Opened 7 years ago

Closed 5 years ago

#6811 closed defect (fixed)

WLAN doesn't reassociate with known access points

Reported by: wad Owned by: dcbw
Priority: high Milestone:
Component: network manager Version: Development build as of this date
Keywords: WLAN WIFI release? Cc: mstone
Blocked By: Blocking:
Deployments affected: Action Needed: test in build
Verified: no

Description

The expected behavior of an XO is that if it doesn't find a school mesh (or "laptop as MPP" mesh), it will try to associate with WiFi APs that it has previously been associated with.

In the 69x builds (particularly 699), this has not been working reliably (for example, see:
http://wiki.laptop.org/go/Collab_Network_School_Wifi_Tests#Test_0323K
)

But with build 703, I'm seeing that association with a previous selected access point tends to work, with occasional failures. Attached are logs taken from the same laptop. Once when it succeeded, and once when it fails.

In previous tests, I noticed a zero length /home/olpc/.sugar/default/nm/networks/cfg file, which could have contributed to the problem. That file was verified to have the correct information in these tests.

Attachments (4)

messages_failure (67.6 KB) - added by wad 7 years ago.
/var/log/messages from a laptop that failed to reassociate with a known AP
messages_success (44.6 KB) - added by wad 7 years ago.
/var/log/messages from a laptop that reassociated with a known AP
logs_success.zip (151.8 KB) - added by wad 7 years ago.
Sugar/telepathy logs from a laptop that reassociated with an AP
logs_failure.zip (188.6 KB) - added by wad 7 years ago.
Sugar/telepathy logs from a laptop that failed to reassociate with an AP

Download all attachments as: .zip

Change History (12)

Changed 7 years ago by wad

/var/log/messages from a laptop that failed to reassociate with a known AP

Changed 7 years ago by wad

/var/log/messages from a laptop that reassociated with a known AP

Changed 7 years ago by wad

Sugar/telepathy logs from a laptop that reassociated with an AP

Changed 7 years ago by wad

Sugar/telepathy logs from a laptop that failed to reassociate with an AP

comment:1 Changed 7 years ago by wad

Looking at the failed logs, it successfully DHCP'd with the known AP the first time, then failed when it tried to renew the second time. This is not a stellar example of the behavior seen. I will try to get logs from a machine failing upon first boot.

comment:2 Changed 7 years ago by mstone

  • Cc mstone added

comment:3 Changed 7 years ago by mstone

  • Keywords release? added

comment:4 Changed 7 years ago by wad

This is possibly a duplicate of #4975.

More logs of this problem available at:
http://wiki.laptop.org/go/Collab_Network_School_Wifi_Tests#No_Association

comment:6 Changed 6 years ago by gregorio

  • Milestone Never Assigned deleted

Milestone Never Assigned deleted

comment:7 Changed 6 years ago by gregorio

  • Action Needed set to test in build

Can we restest this and close it or reproduce it?

Thanks,

Greg S

comment:8 Changed 5 years ago by Quozl

  • Resolution set to fixed
  • Status changed from new to closed

On recent XO-1.5 builds this is fixed. Closing.

Note: See TracTickets for help on using tickets.