Ticket #685 (closed defect: fixed)

Opened 8 years ago

Last modified 7 years ago

Failure to power up

Reported by: Quozl Owned by: David.Lin
Priority: high Milestone: BTest-3
Component: hardware Version:
Keywords: Cc: vance.ke@…, luna.huang@…, rsmith
Action Needed: Verified: yes
Deployments affected: Blocked By:
Blocking:

Description

Sometimes a unit will fail to power up when asked to using the power button.

The symptom is that a click from the speakers is heard, the power LED lights up, the wireless LED lights up, but the expected light-up of the display does not occur.

Holding the power button down to turn off, works fine. Turning the unit back on reproduces the problem.

Workaround is to remove external power, remove battery, wait ten seconds, then restore.

Problem has been observed on all three units. One unit did it yesterday, two units did it this morning.

The history of the units ...

  • several days ago EC Q2B16 was installed,
  • several discharge and charge cycles have happened,
  • about 14 hours previously, a one-hour discharge to about 60% capacity,
  • charged to full capacity,
  • left overnight powered down with batteries but without AC supply, room temperature 29C to 24C.

The discharge and charge cycle was monitored ... I have logs of voltage, current, capacity and temperature during it.

May relate to ticket #637, except that the batteries are not low, and are able to run the units fine after a removal.

Actions following:

  • removed AC power,
  • took batteries out of units to measure voltage open circuit, each battery pack shows 6.75V, 6.75V and 6.73V,
  • inserted batteries, but not AC power,
  • powered up (each unit powered up fine),
  • began monitoring, first sample of psu_0/voltage shows 6512, 6450, 6448, voltage declining as expected, but not particularly low.

Change History

follow-up: ↓ 2   Changed 8 years ago by mfoster

  • owner changed from mfoster to ted.juan
  • priority changed from low to high
  • milestone changed from Untriaged to BTest-2

Reassigning to Ted for EC firmware resolution - this has been seen in the past with prior EC versions. Also increasing priority to high - this is a key issue. Thank you!

in reply to: ↑ 1   Changed 8 years ago by Quozl

Additional information: able to reproduce the problem on all three units the next day, by following this procedure:

  1. begin with fully charged batteries, (charged in units, using EC firmware version Q2B16, after a forty minute or so discharge so as to force charging to commence,)
  2. use poweroff command to shutdown each unit,
  3. wait for shutdown to complete (power LED to extinguish),
  4. turn off AC supply to AC adaptors,
  5. wait 12 hours,
  6. press power button to turn on each unit.

Result was again speaker click, power LED, wireless LED, but no screen backlight, no USB power (tested with flash drive insertion), and no booting.

follow-up: ↓ 5   Changed 8 years ago by Quozl

Richard Smith asked for battery voltages again, in case the batteries were at fault. Tests done just now:

  1. measured voltages of each battery open circuit, results were 6.80V, 6.81V and 6.76V,
  2. inserted each battery into laptop, powered up laptop, with AC adaptors disconnected,
  3. recorded psu_0/capacity, results were 94%, 94%, and 94%,
  4. recorded psu_0/voltage, results were 6500, 6546, and 6474,
  5. noted that temp2 is showing 50000,
  6. noted that voltage and capacity decline as expected.

My conclusion is that the batteries are not at fault, but rather the EC or other components enter a non-functioning mode as a result of being left idle.

  Changed 8 years ago by ted.juan

  • status changed from new to assigned

in reply to: ↑ 3   Changed 8 years ago by David.Lin

Replying to Quozl: We are unable to see this kind of situation now, whether you can tell me how to make the battery into under voltage 7000 and 94% full. Whether these batteries have ever made over charge or other experiments.

  Changed 8 years ago by Quozl

These batteries have not been used in other experiments, and have only been used in the B-Test-1 units. They have not been charged except through EC firmware control.

Over charge may have happened on 2006-12-19, read ticket #596 for battery history, note the temperature observation "too hot to hold". This was not intentional, but apparently caused by defect.

Regardless, it may be possible for batteries to be over charged by other means external to the unit ... they are removable batteries ... so the firmware should take that into consideration. The firmware should not assume it has continuous control over the batteries.

  Changed 7 years ago by ted.juan

  • cc vance.ke@…, luna.huang@… added
  • status changed from assigned to new

  Changed 7 years ago by ted.juan

  • owner changed from ted.juan to David.Lin

  Changed 7 years ago by David.Lin

  • status changed from new to assigned

  Changed 7 years ago by jg

  • cc rsmith added
  • milestone changed from BTest-2 to BTest-3

David, is this fixed?

  Changed 7 years ago by David.Lin

  • status changed from assigned to closed
  • resolution set to fixed

This bug is fixed.

Note: See TracTickets for help on using tickets.