Opened 6 years ago

Closed 3 years ago

#6944 closed defect (worksforme)

UI confuses which AP you are connected to

Reported by: yani Owned by: mtd
Priority: high Milestone: 8.2.0 (was Update.2)
Component: sugar Version:
Keywords: polish:8.2.0 blocks-:8.2.0 Cc: marco, tomeu, kim, carrano, mtd, dsd
Blocked By: #4074 Blocking: #6872, #8592
Deployments affected: Action Needed: code
Verified: no

Description

This bug is similar to #5495.

To have the effect you
1) Click on a AP that will take long to connect(like a WEP/WPA ap)
2) While it blinks, you click another AP that will connect instantly(like medialab in 1cc)
3) The second AP /will/ connect, but the main view will show the colours of the first AP. However, when u hover over the circle it shows the correct info.

This can be very confusing. The main view & neighbor view disagree and you dont know what to trust.

The screenshots show the mismatch

The bug is 100% consistent when you follow the above steps

Attachments (2)

screen1.png (34.7 KB) - added by yani 6 years ago.
screen2.png (47.5 KB) - added by yani 6 years ago.

Download all attachments as: .zip

Change History (19)

Changed 6 years ago by yani

Changed 6 years ago by yani

comment:1 Changed 6 years ago by yani

correction... i meant similar to #5459 not 5495

comment:2 Changed 6 years ago by mtd

  • Cc mtd added

comment:3 Changed 6 years ago by marco

  • Keywords 8.2.0:? needs-testing added
  • Milestone changed from Never Assigned to 8.2.0 (was Update.2)

comment:4 Changed 6 years ago by marco

  • Action Needed set to diagnose
  • Keywords 8.2.0:? needs-testing removed

comment:5 Changed 6 years ago by mtd

This should be handled by #6995 but is a strict subset of that bug. The problem is almost certainly that the nmclient.py's signals are not being processed correctly by the "main view" (shell's) AP class (wireless.py). The signal handling has changed for #6995: http://dev.laptop.org/git?p=users/mdengler/sugar;a=commitdiff;h=51512861cde94daeccb6c986bd4b4199798545af

comment:6 Changed 6 years ago by mstone

  • Blocked By 6995 added

(In #6995) Martin's screenshots are so attractive that we're willing to test out his work and, assuming it more-or-less succeeds, to include it. :)

comment:7 Changed 6 years ago by marco

  • Keywords polish:8.2.0 added

comment:8 Changed 6 years ago by mtd

  • Blocked By 3993 added; 6995 removed

As part of submitting a patch for #3993, I'm convinced this is indeed part of #6995, but it's the #3993 part of that bug. Changing the blocked-by appropriately.

comment:9 Changed 6 years ago by mtd

  • Action Needed changed from diagnose to code

comment:10 Changed 6 years ago by mtd

  • Action Needed changed from code to package
  • Owner changed from marco to mtd

I've pushed some patches from #2866 that fix this to sucrose-0.82.

|TestCase|

Go to the Neighborhood view. Expose the frame via the frame key. Click on an AP icon that will take a long time to complete association. While the AP's new frame icon is still pulsing, click on another AP icon in the neighborhood view. Observe the frame icon's colours change to match. Check the frame icon's palette's primary text to ensure that it shows the SSID of the second (most-recently-clicked) AP.

|TestCase|

[This is not stricly the behavior noted by the bug report, but could be fixed now] Expose the frame via the frame key. Try to associate with a mesh channel when there's no school server around. Observe a pulsing mesh icon in the frame. While still pulsing away, click on a wireless AP icon in the Neighborhood view. Check that the pulsing mesh icon goes away and is replaced by a pulsing AP icon (that stops pulsing when it finishes connecting, of course).

comment:11 Changed 6 years ago by marco

  • Action Needed changed from package to test in build

comment:12 Changed 6 years ago by mtd

  • Action Needed changed from test in build to code
  • Blocked By 6995 added; 3993 removed
  • Keywords blocks-:8.2.0 added

In joyride-2369, the first test case is passed. The second test case is failed.

It appears I was wrong about #3993 being the root problem here.

The original problem report - attempt connection to slow AP, then successfully connect to fast AP, and sugar shows one as connected to slow AP - is fixed. However this very similar problem report is not: attempt connection to slow AP #1, then attempt connection to slow AP #2, and sugar shows one as connecting to slow AP #1.

So this is technically fixed but I don't think it should be closed.

I also think it *will* be closed by #6995. I'm syncing this bug's tags with #6995's, but I think those need updating...

comment:13 Changed 6 years ago by mtd

  • Blocked By 4074 added

comment:14 Changed 6 years ago by mtd

  • Blocking 8592 added

(In #8592) Replying to thomaswamm:

The symptom of AP and mesh icons both showing in frame was previously reported in #4074, so this might be a regression.

I don't think #4074 was ever really fixed; consider #6944 (and also #5459, #6872).

I'll update #4074. Perhaps we should close this as a dupe.

comment:15 Changed 6 years ago by mtd

  • Blocking 6872 added

comment:16 Changed 3 years ago by dsd

  • Blocked By 6995 removed

Can't reproduce on 11.2.0, after quickly trying to connect to 2 APs, the colours shown in the frame device are correct (in terms of the 2nd AP clicked).

comment:17 Changed 3 years ago by dsd

  • Cc dsd added
  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.