Ticket #7001 (new defect)

Opened 6 years ago

Last modified 5 years ago

XO's Camera not working with Flash Player

Reported by: maverick Owned by: jg
Priority: high Milestone:
Component: distro Version: Update.1
Keywords: Cc: Blaketh
Action Needed: never set Verified: no
Deployments affected: Blocked By:
Blocking:

Description

We are planning to create web based activity for XO using (Adobe Flash ).

the activity we have created uses web camera, and is built in Flash, and its works well when running in firefox in (Windows and Fedora-7), but it dosent show viedo in XO.

Could any one figure it out why..

Change History

Changed 6 years ago by Blaketh

  • cc Blaketh added

It's a possibility that you require Flashcam: http://www.swift-tools.net/Flashcam/.

Changed 6 years ago by gregorio

  • milestone deleted

Milestone Never Assigned deleted

Changed 5 years ago by gnu

  • next_action set to never set

Appears to still be broken in 8.2.0, according to this devel posting:

Date: Fri, 2 Jan 2009 22:56:59 +0800 From: "Carlos Nazareno" <object404@…> To: devel@… Subject: Re: Problems with Adobe Flash player on the XO.

Hi Stan!

I'm having problems: Adobe FlashPlayer doesn't detect the XO's built-in webcam so it can't transmit video out to the Internet on Flash-enabled web sites,

I've documented this problem as well at http://wiki.laptop.org/go/Adobe_Flash -> The XO's webcam is not interfacing properly with Adobe Flash 9 & 10. Adobe's done a lot of work towards getting cameras in various Linux distros working with webcam enabled-Flash apps, and they finally got V4L2 running last year, but apparently the XO is using some kind of not-as-common chipset/software combo (in 8.2.0 I think the OS is using a weird mishmash of old & new software/drivers because of problems with the cam in the webcam activity on newer drivers?).

I got in touch with some Adobe guys last year before Flash Player 10 final launched about Flash's webcam interfacing problems on the XO, filed the bug report, followed their instructions and submitted the hardware info gathered from the data-gathering tool at Penguin.swf's (Adobe's official Linux Flash dude) blog:

http://blogs.adobe.com/penguin.swf/2008/07/paparazzi_v2_1.html

Anyway, I haven't heard a word from the Adobe folks yet as I guess that was a very busy time for them with Flash 10 final release going out the door at the time, the report probly got lost in all the hubbub. Anyway, I'll try following up with them as I'd like to play with writing some Flash webcam toys that would work on the XO myself.

I can't get Flash to activate the XO's camera... ...This was while running on the XO's Browse activity.

The camera works with the Browse Activity, just not properly (the camera turns on and it displays red & green static that reacts to objects waved in front of the camera)

Note: See TracTickets for help on using tickets.