Ticket #7090 (closed defect: fixed)

Opened 6 years ago

Last modified 3 years ago

Read activity crashes if you zoom PDF

Reported by: skierpage Owned by: morgs
Priority: normal Milestone: 11.2.0-M3
Component: read-activity Version: Development build as of this date
Keywords: Cc: sayamindu
Action Needed: no action Verified: no
Deployments affected: Blocked By:
Blocking:

Description

I did olpc-update 703 then ran Bert's script to reinstall activities.

Read activity version 45 crashes/exits when I browse built-in PDFs. Two examples:

* Open Browse (Web), navigate to  file:///usr/share/activities/worldfactbook-maps, open africa.pdf. After this downloads open Journal and run it. Choose View, repeatedly click zoom icon. After about 7 zooms, Read vanishes!

* Open Browse (Web), navigate to Books > Short texts > Solar System. After this downloads open Journal and run it. Scroll to page 5 "The Sun", choose View, repeatedly click Zoom to 334%, Read vanishes!

There's nothing in the Journal or console window, the activity just goes away and Sugar displays the previous view level you were at. In ps alx output I noticed the readactivity's VSZ was 112440 and RSS 78516 a few steps before it exited.

This sounds like bug #5862, or might be a use case for bug #6002.

Change History

Changed 6 years ago by marco

  • status changed from new to closed
  • next_action set to never set
  • resolution set to duplicate

Changed 6 years ago by skierpage

  • status changed from closed to reopened
  • version changed from Update.1 to Development build as of this date
  • resolution duplicate deleted
  • milestone set to 8.2.0 (was Update.2)

This still happens with Read 49 on joyride-2273. For example, if I open the Sugar Handbook (in Browse at OLPC Library > activities > find activities, link near the bottom), View > Zoom to 400%, then page forward and back, my XO gets really slow, the cursor stops tracking, then Read goes away. Nothing in the Read activity log seems relevant.

I couldn't tell the bug number of which marco resolved this as duplicate. #6002 is closed as an upstream bug, but this is a significant usability problem (albeit with no loss of data). So I reopened this, sorry if I did the wrong thing.

FYI this happens to me in normal use because I get confused which game button does what, so I click the wrong one to page down, and because zoom takes time without any feedback I click it again.

Changed 6 years ago by morgs

  • status changed from reopened to new
  • owner changed from rwh to morgs

Changed 6 years ago by marco

  • next_action changed from never set to design

I doubt this can be solved for 8.2 :/ We need to see if upstream solved this and update sugar-evince if that's the case. There are other bugs open about that.

Changed 6 years ago by marco

  • milestone changed from 8.2.0 (was Update.2) to 9.1.0

Changed 6 years ago by cjl

This is still a problem in 8.2-759 with Read 50. The most common failure case is probably a kid looking to see their own country in the pre-loaded WorldBook maps (from Broswse sidebar) and using zoom. For the pre-loaded content, this could be mitigated by changing formats as suggested in #7652. It would be good if someone were to politely poke upstream about it, but I just looked at the evince-list archives and I haven't seen anything about it since January.

 http://mail.gnome.org/archives/evince-list/2008-January/msg00005.html

If no one follows up, it is unlikely this will get the attention it deserves.

Changed 6 years ago by gregorio

  • cc sayamindu added

Changed 6 years ago by morgs

  • deployment_affected set to Rwanda

Changed 6 years ago by morgs

  • deployment_affected Rwanda deleted

Changed 6 years ago by Sam Douglas

It seems like a fairly serious problem, exacerbated by the XO's low memory and lack of swap space. I have managed to duplicate this bug on every PDF I have tried. Repeatedly clicking zoom in, or using the game keys to do it will crash Read. On candidate-801

Changed 3 years ago by godiard

  • next_action changed from design to test in build
  • milestone changed from 9.1.0-cancelled to 11.2.0-M3

It's working ok. I have tested it in XO-1 too.

Must be closed

Changed 3 years ago by greenfeld

  • status changed from new to closed
  • next_action changed from test in build to no action
  • resolution set to fixed

I was unable to get read to crash with multiple PDFs in most cases with an XO-1 and 1.5. I tried 4 PDFs from various sources as well as the two mentioned above.

With some image-containing (if not full-page image) copyrighted PDFs I should not copy around I was able to get an XO-1 to kill read using Linux's out of memory handler. But it took quite a bit of zooming around and to do so, and I couldn't reliably do this with some custom-made PDFs. I will look at the copyrighted ones in more detail to see if I figure out their DPI, etc. is coming into play vs. the XO-1's 256 MB of RAM, and file a new bug if they aren't doing something extreme.

Note: See TracTickets for help on using tickets.