Opened 7 years ago

Closed 4 years ago

#7091 closed defect (fixed)

no preview thumbnail in Journal for PDFs in Read activity

Reported by: skierpage Owned by: joe
Priority: normal Milestone: 8.2.0 (was Update.2)
Component: read-activity Version: Update.1
Keywords: Read-50:+ joyride-2301:+ Cc: morgs
Blocked By: Blocking:
Deployments affected: Action Needed: qa signoff
Verified: no

Description

After I view a PDF in the Read activity version 45 (on build 703), the Journal shows "No preview" for the PDF. You can reproduce with the PDFs on the XO, e.g. World Fact Book or Books > Short texts > Solar System.

The Evince package underlying Read can generate thumbnails, it comes with an evince-thumbnailer program.

For bonus points the Journal preview thumbnail could change to show the last page you were reading.

Change History (5)

comment:1 Changed 6 years ago by gregorio

  • Milestone Never Assigned deleted

Milestone Never Assigned deleted

comment:2 Changed 6 years ago by marco

  • Action Needed set to diagnose
  • Milestone set to 8.2.0 (was Update.2)

comment:3 Changed 6 years ago by morgs

  • Owner changed from rwh to morgs

comment:4 Changed 6 years ago by morgs

  • Action Needed changed from diagnose to qa signoff
  • Cc morgs added
  • Keywords Read-50:+ joyride-2301:+ added
  • Owner changed from morgs to joe

Fixed in Read-50 - I think this was due to metadata not being saved. It works for me now.

Test case: Open a PDF in Read. Stop the activity. Go to the detailed view in Journal. The thumbnail should show a screenshot of what you were last reading.

comment:5 Changed 4 years ago by godiard

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.