Opened 6 years ago

Closed 6 years ago

#7158 closed defect (fixed)

Upgrade from 656 to 703 leaves su unusable when you fallback to 656.

Reported by: cscott Owned by: cscott
Priority: normal Milestone: 8.2.0 (was Update.2)
Component: upgrade utility Version: Build 656
Keywords: 8.2.0:? Cc: kimquirk
Blocked By: Blocking:
Deployments affected: Action Needed: test in build
Verified: no

Description

olpc-update from 656 to 703 apparently writes through the hardlink of su to change its ownership, which makes 'su' unusable if/when you use 'alt boot' to fall back to 656.

The "real" solution is actual copy-on-write support in the upgrade system, but a short-term workaround would be to have olpc-update forcibly unlink /bin/su in olpc-update.

Change History (12)

comment:1 Changed 6 years ago by cscott

Hmm. The original complaint I received stated that this problem would prevent them from obtaining root to fix the problem, but 656 lets you log in as root from the console with no password. So I don't think the severity of this bug is very high. I'm investigating...

comment:2 Changed 6 years ago by cscott

OK, confirmed that (a) this bug doesn't prevent you from logging in as root from the console, (b) that olpc-update in 656 does change the permissions on /bin/su w/o breaking the hard link, (c) olpc-update 2.7 (in a joyride near you!) fixes this problem "correctly".

comment:3 Changed 6 years ago by gregorio

  • Milestone Never Assigned deleted

Milestone Never Assigned deleted

comment:4 Changed 6 years ago by gregorio

  • Action Needed set to never set

Does this problem still apply when upgrading from 656 to 8.2.0?

If not I'm taking it out of the release notes.

Thanks,

Greg S

comment:5 Changed 6 years ago by mstone

  • Action Needed changed from never set to test in build
  • Keywords 8.2.0:? added
  • Milestone set to 8.2.0 (was Update.2)
  • Version changed from Update.1 to Build 656

Greg: it needs to be retested. I believe that the contents of the 703 image tickled a bug in the 656 update software. I don't know whether the joyrides tickle the same bug.

comment:6 Changed 6 years ago by cscott

  • Owner changed from cscott to gregorio

Yes, it's definitely a release note for upgrades from 656 and possibly from 703 and 708 (but not from joyride or 8.2-series). It's not a high severity bug because in the default configuration of 656, 703, and 708 doesn't require su to get root.

Reassigning because the bug in olpc-update has been fixed for new releases, and there's not a lot we can do about the old releases.

comment:7 Changed 6 years ago by gregorio

  • Cc kimquirk added
  • Owner changed from gregorio to cscott

Hi Scott,

How about this for the 8.1.1 release notes: http://wiki.laptop.org/go/Release_Notes/8.1.1#What.27s_the_recommended_way_to_upgrade.3F

"When upgrading from build 656 or earlier releases via olpc-update (add URL), if you decide to revert back after upgrading (see: http://wiki.laptop.org/go/Support_FAQ#How_can_I_restore_my_Give1Get1_XO_to_its_factory_configuration.3F) you will not have access to the su (Super User) account in the terminal activity."

Let me know if that conveys the correct info and I can add it to the release notes.

Also, let me know which release this affects (e.g. from nnn and to mmm). Does it affect 656 to 708? How about 703 to 708?

Thanks,

Greg S

comment:8 Changed 6 years ago by cscott

The link is misleading, because "how can I restore" links to reflash instructions. Doing a clean reflash will clearly fix the su issue. The "revert back" is only the use of the 'O' key to do an alternate boot into the old image.

A user can also upgrade olpc-update before upgrading to avoid the problem, or use olpc-update 656 to revert; either of those will also avoid the problem. The issue is *only* with the use of the 'O' key to fall back.

comment:9 Changed 6 years ago by cscott

  • Owner changed from cscott to gregorio

comment:10 Changed 6 years ago by gregorio

Hi Scott,

Good catch, thanks!

How about this instead:

  • {{Ticket|7158}} Upgrade from 656 to 708 (AKA 8.1.1) leaves su unusable when you fallback to 656. This bug will only affect you if you upgrade to 8.1.1 and then "revert" to 656 by holding down the "O" game key on boot up. If you "clean install" 8.1.1 or revert to 656 by a "clean install" of that, you will not encounter this bug.

Currently visible at: http://wiki.laptop.org/go/Release_Notes/8.1.1#Notable_Current_Bugs

and

http://wiki.laptop.org/go/Release_Notes/8.1.0#Notable_Current_Bugs

Thanks,

Greg S

comment:11 Changed 6 years ago by gregorio

  • Owner changed from gregorio to cscott

comment:12 Changed 6 years ago by cscott

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.