Opened 7 years ago

Closed 6 years ago

#7233 closed defect (fixed)

Unreadable project titles

Reported by: subbu Owned by: etoys
Priority: normal Milestone:
Component: etoys-activity Version: Development build as of this date
Keywords: fonts Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: never set
Verified: no

Description

In etoys.image shipped in Squeakland-OLPC-080512.zip, titles for new projects appear smeared and unreadable (see second projectviewmorph in attached picture). I tried changing default text font to 9 and 12 but that did not improve readability. I could read it fine if I click on the title to edit, but the stenciled title was unreadable. I tried changing the font to Komika and Accuny and only the latter was readable (first projectviewmorph in the attached picture).

While browsing, I found another bug(?) in >>fontForName method. The last line reads:

(TextStyle default fontAt: 1)

In Etoys 3.0, the default fontAt: 1 is BitstreamVeraSans 5pt which is very tiny. Should the first default font be changed to 8pt?

Subbu

Attachments (1)

badtitles.jpg (5.4 KB) - added by subbu 7 years ago.

Download all attachments as: .zip

Change History (10)

Changed 7 years ago by subbu

comment:1 Changed 7 years ago by bert

Please do not put multiple issues into one ticket. The 5-pixel font issue already has a separate ticket: #4944 (and I agree with you but Yoshiki thinks otherwise).

comment:2 Changed 7 years ago by ohshima

Because the small font is used already, and the user can add any sized font at any point, any code that assumed the font index and font size tied is wrong. I'm not sure what Bert doen't agree and what Bert agrees, but removing the particular small font is not a solution. I'll make up a change soon.

comment:3 Changed 7 years ago by bert

Hehe. I agree that code should not rely on font size indices, and if it does, it is a bug. Removing the 5 pixel font from the menu is not intended to be a solution to that, but simply to remove an obviously odd option.

comment:4 Changed 7 years ago by ohshima

For the project titles (and the name in ThreadNavigator) is fixed by 2012fontInProjView-yo.

comment:5 Changed 7 years ago by subbu

  • Resolution set to fixed
  • Status changed from new to closed

2012fontInProjView-yo fixes this ticket, but the general problem of absolute font indexes remains. I have created another ticket #7244 to track it.

I was using Squeakland-OLPC etoys.image and didn't realize that its update URL was different from that of XO Etoys :-(.

comment:6 Changed 6 years ago by subbu

  • Action Needed set to never set
  • Keywords fonts added
  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Version changed from Update.1 to Development build as of this date

2012fontInProjView-yo fixes the problem for etoys-dev-3.0 image which uses Accuny fonts but not in the released etoys.image. ReleaseBuilder for OLPC sets the default text font to Bitstream Vera Sans. The titles are unreadable with BVS fonts. The error can be reproduced in etoy-dev-3.0 image by setting default font to Bitstream Vera Sans 9 pt.

comment:7 Changed 6 years ago by ohshima

Ok, I pushed another changeset to the stream. It changes the look a bit but simpler and faster. How do you like it?

comment:8 Changed 6 years ago by gregorio

  • Milestone Never Assigned deleted

Milestone Never Assigned deleted

comment:9 Changed 6 years ago by bert

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.