Opened 7 years ago

Closed 6 years ago

#7267 closed defect (fixed)

audit_log_user_command() error when becoming root

Reported by: dsd Owned by: jg
Priority: low Milestone: 8.2.0 (was Update.2)
Component: distro Version: olpc-3
Keywords: Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: never set
Verified: no

Description

Running olpc3-17. When becoming root, e.g. running "sudo su -" at terminal activity, the following (harmless?) message is printed:

audit_log_user_command(): Connection refused

Change History (4)

comment:1 Changed 7 years ago by dsd

after the above message is printed, I am presented with a root shell, so things is working bar the strange message.

comment:3 Changed 7 years ago by dsd

The message is indeed harmless, it's caused by a fedora-specific sudo patch which integrates sudo with libaudit.

The message appears because we don't have CONFIG_AUDIT enabled in the kernel (whereas Fedora kernels do). I posted a fix to the upstream bug.

comment:4 Changed 6 years ago by dsd

  • Action Needed set to never set
  • Resolution set to fixed
  • Status changed from new to closed

joyride now has olpcsudo which doesn't have this harmless bug

Note: See TracTickets for help on using tickets.