Opened 6 years ago

Closed 4 years ago

#7378 closed defect (fixed)

Trim down olpc-library-core.

Reported by: cscott Owned by: mstone
Priority: high Milestone: 8.2.0 (was Update.2)
Component: library Version: Update.1
Keywords: polish:8.2.0 Cc: mstone, sj, dsd
Blocked By: Blocking: #7413, #7423, #7524
Deployments affected: Action Needed: code
Verified: no

Description

Many bits of olpc-library-core are either (a) inappropriate for non-English speakers, or (b) better spun off as independent library bundles. The English-only wikibooks are an example of the first; the 'bundle-archive' is an example of the second (since countries should be at liberty to include different or newer versions of activities without updating the core).

Change History (9)

comment:1 Changed 6 years ago by cscott

  • Blocking 7413 added

comment:1 Changed 6 years ago by cscott

  • Blocking 7413 removed

Sj: PING!

comment:2 Changed 6 years ago by cscott

  • Blocking 7413 added

Oops, didn't mean to delete the 'blocking' flag.

comment:3 Changed 6 years ago by cscott

  • Cc sj added
  • Owner changed from sj to mstone

Reassigning to mstone, since he said that sj deputized him to find someone to do this.

comment:4 Changed 6 years ago by dsd

  • Cc dsd added

Fixing (b) is obvious - just create new external bundles of the content - but how would someone fix (a)? Same thing?

comment:5 Changed 6 years ago by cscott

  • Blocking 7423, 7524 added

comment:6 Changed 6 years ago by mstone

  • Action Needed changed from never set to code

comment:7 Changed 6 years ago by cscott

  • Keywords polish:8.2.0 added

comment:8 Changed 4 years ago by dsd

  • Resolution set to fixed
  • Status changed from new to closed

The library content has been split from core for a long time now.

Note: See TracTickets for help on using tickets.