Opened 6 years ago

Closed 3 years ago

#7384 closed task (fixed)

Manually enabled USB-disabling Power Management

Reported by: gregorio Owned by: joe
Priority: normal Milestone: 8.2.0 (was Update.2)
Component: release-contract Version:
Keywords: 8.2.0:+ joyride-2134:? Cc: mstone, gregorio, cjb, dgilmore, joe, mtd, gnu
Blocked By: #7434, #8916 Blocking:
Deployments affected: Action Needed: no action
Verified: no

Description

Steps to release:

  1. Try out in joyride. (Which build?). (???)
  1. Package any necessary UI changes. (cjb, ???)
  1. Include in a release-stream build. (Michael)
  1. Execute the best available regression test. (Joe)
  1. ...

(NB: Please annotate this release contract with all relevant tickets and wiki pages.)

Change History (9)

comment:1 Changed 6 years ago by cjb

Hi,

Which build?

joyride-2079 works well, as in http://permalink.gmane.org/gmane.linux.laptop.olpc.devel/14946

comment:2 Changed 6 years ago by cjb

Some progress:

  • The Sugar patches to the control panel have been submitted for review (Trac #7434)
  • The OHM patches required have been committed, built and tagged into OLPC-3, so should be present in the next Joyride build:
[cjb@localhost OLPC-3]$ koji latest-pkg dist-olpc3 ohm
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
ohm-0.1.1-6.14.20080707git.olpc3          dist-olpc3            cjb

Still to come:

  • Perhaps expose the "number of seconds until suspend" parameter in the control panel section
  • OHM should load the current settings from the Sugar profile at OHM startup time

comment:3 Changed 6 years ago by cscott

  • Blocked By 7434 added

comment:4 Changed 6 years ago by mstone

  • Action Needed changed from communicate to test in build
  • Keywords joyride-2134:? added
  • Owner changed from cjb to joe

The "power" control panel patches landed in joyride-2134. Please test.
Chris, Simon: where can we find test cases for both the power management itself and for using the control panel to manipulate it?

comment:5 Changed 6 years ago by mtd

  • Cc mtd added

I've tested, and have found #7690 - a latent issue that this (#7384) new (cool :)) feature has exposed. Not sure what (if anything) wants to be done about it.

comment:6 Changed 6 years ago by gnu

  • Cc gnu added

comment:7 Changed 6 years ago by mtd

I can't find a way of phrasing this that doesn't sound annoying, but I'm not trying to be: the changes now in ohm disable the wireless radio, but there is no "usb-disabling" component to the code changes, right? That just seems slightly at odds with the ticket's title. Which (the title or the code) is the correct description of the intended changes?

comment:8 Changed 6 years ago by gnu

  • Blocked By 8916 added

comment:9 Changed 3 years ago by greenfeld

  • Action Needed changed from test in build to no action
  • Resolution set to fixed
  • Status changed from new to closed

Ohmd has been replaced by powerd, and the extreme power management option (disabling wireless/USB) is no longer available.

Note: See TracTickets for help on using tickets.