Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#7407 closed defect (fixed)

Rotating the screen causes X lockup (xrandr broken)

Reported by: erikg Owned by: ApprovalForUpdate
Priority: high Milestone: 8.2.0 (was Update.2)
Component: not assigned Version: Development build as of this date
Keywords: joyride-2269:+ 8.2-759:+ Cc: Rmyers, pepe, erikg
Blocked By: Blocking:
Deployments affected: Action Needed: test in release
Verified: no

Description

In joyride-2078 and joyride-2079, pressing the rotate button causes a slow white-out of the display.

The problem appears to be xrandr-related. Running xrandr -o 'left' in the terminal activity causes the same lockup.

Attachments (1)

fix-rotate.patch (1.2 KB) - added by erikg 6 years ago.
patch from CosmicPenguin (Jordan Crouse), apply to xf86-video-geode git HEAD.

Download all attachments as: .zip

Change History (26)

comment:1 Changed 6 years ago by erikg

  • Milestone changed from Never Assigned to 9.1.0
  • Owner set to erikg
  • Status changed from new to assigned
  • Version changed from Update.1 to Development build as of this date

comment:2 Changed 6 years ago by erikg

I have produced the identical issue by running 'xrandr -o left' in the Terminal.

comment:3 Changed 6 years ago by dsd

  • Cc dsd added
  • Keywords 8.2.0:? added

I think we should change milestone? This is an 8.2 regression which we should fix before release.

comment:4 follow-up: Changed 6 years ago by dsd

BTW, Brian made an interesting observation. This is not a complete freeze, because if you press the rotate button 4 times then you get your display back.

comment:5 in reply to: ↑ 4 Changed 6 years ago by erikg

Replying to dsd:

BTW, Brian made an interesting observation. This is not a complete freeze, because if you press the rotate button 4 times then you get your display back.

Wow. Interesting.

For what it's worth I've established that the problem isn't in the xrandr executable. Digging into the Xrandr library.

comment:6 Changed 6 years ago by erikg

CosmicPenguin (per discussion in #xorg-devel) suggests that the problem is likely a loss of sync between the DCON and the GPU.

comment:7 Changed 6 years ago by Rmyers

  • Cc Rmyers added

replying to dsd:

In more recent builds, four rotations _do_ _not_ get you back.

I reported this issue as 7651 (just closed as dup of this. As of 2137 -- earliest I tried, once the screen's goen it stays gone. Still there in 2230.

Replying to erikg:

But it used to work. Isn't it more likely a regression on our part?

comment:8 Changed 6 years ago by pepe

  • Cc pepe added

comment:9 Changed 6 years ago by cjb

  • Keywords blocks?:8.2.0 added

comment:10 Changed 6 years ago by gregorio

  • Milestone changed from 9.1.0 to 8.2.0 (was Update.2)

comment:11 Changed 6 years ago by gregorio

  • Keywords blocks:8.2.0 added; blocks?:8.2.0 removed

Changed 6 years ago by erikg

patch from CosmicPenguin (Jordan Crouse), apply to xf86-video-geode git HEAD.

comment:12 Changed 6 years ago by dsd

  • Action Needed changed from never set to package

This is a F9 package so I requested upstream inclusion of the patch:
https://bugzilla.redhat.com/show_bug.cgi?id=458382

For the time being, I also added a public_rpm for it, which should be included in the next joyrides.

comment:13 Changed 6 years ago by erikg

I tested and verified the functionality the attached patch on an XO running joyride-2230. It resolves the issue. (dsd has thus moved forward to packaging).

comment:14 Changed 6 years ago by garycmartin

Tested with joyride-2269 on a B4 XO, rotate key is correctly rotating the screen.

comment:15 Changed 6 years ago by mstone

  • Keywords joyride-2269:+ added

comment:16 Changed 6 years ago by dsd

  • Cc erikg added; dsd removed
  • Owner changed from erikg to dsd
  • Status changed from assigned to new

comment:17 Changed 6 years ago by kimquirk

  • Action Needed changed from package to test in build

This can be tested in today's build. Still needs the correct packaging.

comment:18 Changed 6 years ago by kimquirk

  • Keywords 8.2.0:? blocks:8.2.0 removed

In test, this no longer crashes. Will open a new bug taht some laptops don't rotate with the button.
Should be closed as soon as the packaging is done.

comment:19 Changed 6 years ago by dsd

  • Action Needed changed from test in build to add to build
  • Owner changed from dsd to ApprovalForUpdate

Please include xorg-x11-drv-geode-2.10.1-1.fc9 in the 8.2 stream. Right now this is coming from my public_rpms which is not so desirable.

comment:20 Changed 6 years ago by dsd

|TestCase|

Press rotate screen button and check that the XO doesn't immediately die a horrible death

comment:21 Changed 6 years ago by dsd

  • Action Needed changed from add to build to approve for release

comment:22 Changed 6 years ago by mstone

  • Action Needed changed from approve for release to add to release

comment:23 Changed 6 years ago by cscott

  • Action Needed changed from add to release to test in release

Committed changes to stable repo; should be in builds 758 and later. Please test.

comment:24 Changed 6 years ago by dsd

  • Keywords 8.2-759:+ added
  • Resolution set to fixed
  • Status changed from new to closed

confirmed working in build 759

comment:25 Changed 6 years ago by frances

confirmed working from 2 different XOs running 8.2-759

Note: See TracTickets for help on using tickets.