Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#7452 closed defect (fixed)

record activity can only record one video

Reported by: dsd Owned by: dsd
Priority: high Milestone:
Component: camera-activity Version: Development source as of this date
Keywords: 8.2.0:? blocks:8.2.0 Record-57:+ joyride-2363:+ 8.2-759:+ Cc: gregorio, erikg
Blocked By: Blocking:
Deployments affected: Action Needed: test in release
Verified: no

Description

As of latest git (users/dsd/record 1cde6c884):

Record activity can only record one video per session. When you try to record the next one, a frame gets frozen on screen during recording, and when you click the stop button, nothing gets saved.

Attachments (1)

0001-don-t-try-to-reuse-videobin-or-audiobin.patch (1.2 KB) - added by jmatthew 6 years ago.
this patch fixes it for me

Download all attachments as: .zip

Change History (23)

comment:1 Changed 6 years ago by dsd

I think this is a gstreamer bug, that or I'm doing something wrong. http://marc.info/?l=gstreamer-devel&m=121562099110189&w=2

comment:2 Changed 6 years ago by dsd

  • Keywords 8.2.0:? added

comment:3 Changed 6 years ago by gregorio

  • Milestone Never Assigned deleted

Milestone Never Assigned deleted

comment:4 Changed 6 years ago by gdesmott

  • Blocking 7543 added

comment:5 Changed 6 years ago by dsd

I found and fixed the bug preventing my isolated test case from working: http://marc.info/?l=gstreamer-devel&m=121804618419812&w=2

However record still doesn't record more than 1 video :( next step is to isolate the bug again.

comment:6 Changed 6 years ago by cjb

  • Keywords blocks?:8.2.0 added
  • Priority changed from normal to high

comment:7 Changed 6 years ago by kimquirk

Looks like a blocker to me as it is a serious regression from previous release.

comment:8 Changed 6 years ago by gregorio

  • Cc gregorio erikg dsd added
  • Keywords blocks:8.2.0 added; blocks?:8.2.0 removed

Hi Guys,

I agree this is a blocker. Record is probably our most popular activity.

Who is working on this?

Thanks,

Greg S

comment:9 Changed 6 years ago by dsd

  • Cc dsd removed

I am, as I posted here yesterday.

p.s. no need to CC the bug reporter or owner.

comment:10 Changed 6 years ago by dsd

filed the gstreamer bug on upstream bugzilla: http://bugzilla.gnome.org/show_bug.cgi?id=546955

comment:11 Changed 6 years ago by dsd

As pointed out by a gstreamer developer, my record code (and test case) was badly behaved in that it did not let the streams flush before terminating the pipeline. Fixed that in record git, and this also avoids the bug I found with my earlier test case.

But we still can't record more than one video! My test case breaks again when it is brought closer to what record actually does (i.e. capturing audio too, capturing video from the webcam rather than a test source). I don't have any idea where to start digging into this one. http://marc.info/?l=gstreamer-devel&m=121848539729018&w=2

comment:12 Changed 6 years ago by cscott

Does your gstreamer patch help issues, even with your new record code?

This is at risk of becoming a relnote for 8.2. We need progress towards a fix soon if it's going to make the train.

comment:13 Changed 6 years ago by dsd

The patch never fixed record, it just was one step in the process. Now that record has been modified it is not needed (although is still perhaps valid), and we're left with other bugs which are much harder to fix.

My next steps are to look into using the gstreamer that we shipped in update1. I need koji before I can continue with that.

comment:14 Changed 6 years ago by dsd

I can fix this quickly if we're OK with going back to an old gstreamer:
http://lists.laptop.org/pipermail/devel/2008-August/018331.html

Changed 6 years ago by jmatthew

this patch fixes it for me

comment:15 Changed 6 years ago by jmatthew

The patch I just attached fixes this issue for me, on a fairly recent joyride build.

Theoretically, reusing GStreamer elements is supposed to work, but often it doesn't.

comment:16 Changed 6 years ago by dsd

  • Action Needed changed from diagnose to add to build
  • Keywords Record-57:+ joyride-2263:+ added

fixed by reverting gstreamer and record code, need to add to 8.2

comment:17 Changed 6 years ago by dsd

  • Keywords joyride-2363:+ added; joyride-2263:+ removed

comment:18 Changed 6 years ago by cscott

We should keep this bug open so that the patch above doesn't get lost when we unrevert gstreamer.

dsd, I assume the packages affected are the same as for #7887?

comment:19 Changed 6 years ago by dsd

correct

comment:20 Changed 6 years ago by cscott

  • Action Needed changed from add to build to test in release

Added to the stable build stream; will be in 758.

Careful about closing this bug, though; we'll need to fix these problems "for real" in 9.1.

comment:21 Changed 6 years ago by dsd

  • Keywords 8.2-759:+ added
  • Resolution set to fixed
  • Status changed from new to closed

This is working in 759, created #8322 for the real fix

comment:22 Changed 6 years ago by gdesmott

  • Blocking 7543 removed
Note: See TracTickets for help on using tickets.