Opened 6 years ago

Closed 6 years ago

#7457 closed defect (fixed)

Laptops unable to see each other in Joyride

Reported by: Charlie Owned by: joe
Priority: blocker Milestone: 8.2.0 (was Update.2)
Component: presence-service Version:
Keywords: blocks:8.2.0 8.2.0:? Cc: kimquirk, joe, mstone, Collabora, morgs, dsd
Blocked By: Blocking:
Deployments affected: Action Needed: diagnose
Verified: no

Description

Two laptops both running joyride-2128 (CSN74902E58 and CSN74400075) were both unable to see each other on simple mesh, a schoolserver (schoolserver.media.mit.edu) with an access point (not active antenna), and a WEP access point. They were able to access the internet from the AP as well as WEP and WPA access points.

The two laptops were set up by installing build 708 from the instructions on this w.l.o page, and then using olpc-update to upgrade to joyride-2128.

I'm reasonably certain that this should be reproduceable by anyone else, but if logs are needed please let me know which ones to include.

Change History (15)

comment:1 Changed 6 years ago by morgs

  • Action Needed changed from never set to diagnose
  • Cc Collabora morgs added
  • Owner changed from kimquirk to Collabora

I see presence between XOs with current joyride. Please provide presenceservice.log from the XOs who cannot see each other, as well as the output of olpc-netstatus.

comment:2 Changed 6 years ago by Charlie

Several reboots fixed the issues with the media lab schoolserver and the WEP access point (canopy) -- a separate bug altogether it seems -- but the two laptops still cannot see each other on a simple mesh.

I'll add the presenceservice.log files when I get logging re-enabled.

comment:3 Changed 6 years ago by morgs

  • Cc dsd added

Probably a duplicate of #7319 then, please coordinate with dsd

comment:4 Changed 6 years ago by gdesmott

Please, let's discuss this problem on #7319 while we don't have evidence that's a different issue.

comment:5 Changed 6 years ago by gregorio

  • Milestone Never Assigned deleted

Milestone Never Assigned deleted

comment:6 Changed 6 years ago by mstone

  • Keywords blocks:8.2.0 8.2.0:? added
  • Milestone set to 8.2.0 (was Update.2)

comment:7 follow-up: Changed 6 years ago by mstone

Can this be reproduced in joyride>2177?

comment:8 in reply to: ↑ 7 Changed 6 years ago by gdesmott

Replying to mstone:

Can this be reproduced in joyride>2177?

Yeah, still present in Joyride 2179 but I'm pretty sure that's because of #7319

comment:9 Changed 6 years ago by gdesmott

Now #7319 is fixed could you retry with a recent Joyride please?

comment:10 Changed 6 years ago by gdesmott

  • Owner changed from Collabora to Charlie

comment:11 follow-up: Changed 6 years ago by bert

In jr-2233 my laptops could not see each other when connected to the same access point (though ping and ssh worked fine between them). Only when connected to Mesh 1 they showed up in the neighborhood.

comment:12 Changed 6 years ago by Charlie

I'm able to see and collaborate with other laptops while running joyride-2230 on both simple mesh and school wifi just fine.

bert: Are you just on a regular access point? Is there a school server? WPA/WEP?

comment:13 in reply to: ↑ 11 Changed 6 years ago by gdesmott

Replying to bert:

In jr-2233 my laptops could not see each other when connected to the same access point (though ping and ssh worked fine between them). Only when connected to Mesh 1 they showed up in the neighborhood.

Coul you attach presence-service and telepathy log please? See http://wiki.laptop.org/go/Telepathy_debugging

comment:14 Changed 6 years ago by Charlie

  • Owner changed from Charlie to joe

comment:15 Changed 6 years ago by kimquirk

  • Resolution set to fixed
  • Status changed from new to closed

Not reproducible in later builds. Will close for now. Reopen if it comes back.

Note: See TracTickets for help on using tickets.