Opened 6 years ago

Closed 4 years ago

#7467 closed defect (fixed)

Measure broken in joyride

Reported by: dsd Owned by: arjs
Priority: blocker Milestone: 8.2.0 (was Update.2)
Component: measure-activity Version: Development build as of this date
Keywords: Measure-17:- blocks-:8.2.0 Cc: morgs, gregorio, arjs, tomeu
Blocked By: #7856 Blocking:
Deployments affected: Action Needed: review
Verified: no

Description

Measure-17 on joyride-2134 fails to launch with this trace:

---------------------------------------------------------------------------
NotImplementedError                       Traceback (most recent call last)

/usr/lib/python2.5/site-packages/sugar/activity/activity.py in __canvas_map_cb(self=<AnalogInput object at 0x910720c (SugarActivity at 0x8eb8008)>, canvas=<gtk.VBox object at 0x911
6c5c (GtkVBox at 0x8255340)>)
    572     def __canvas_map_cb(self, canvas):
    573         if self._jobject and self._jobject.file_path:
--> 574             self.read_file(self._jobject.file_path)
        self.read_file = <bound method AnalogInput.read_file of <AnalogInput object at 0x910720c (SugarActivity at 0x8eb8008)>>
        self._jobject.file_path = '/home/olpc/.sugar/default/org.laptop.MeasureActivity/data/tmpi8oDXI'
    575
    576     def __jobject_create_cb(self):

/usr/lib/python2.5/site-packages/sugar/activity/activity.py in read_file(self=<AnalogInput object at 0x910720c (SugarActivity at 0x8eb8008)>, file_path='/home/olpc/.sugar/default/org.laptop.MeasureActivity/data/tmpi8oDXI')
    619         notice changes, this is the time to record the originals.
    620         """
--> 621         raise NotImplementedError 
        global NotImplementedError = undefined
    622
    623     def write_file(self, file_path):

NotImplementedError:

Looks like the AnalogInput class needs to be extended to be friendly with the journal.

Change History (15)

comment:1 Changed 6 years ago by gregorio

  • Milestone Never Assigned deleted

Milestone Never Assigned deleted

comment:2 Changed 6 years ago by dsd

  • Keywords 8.2.0:? removed
  • Summary changed from Measure fails to launch in recent sugar to Measure encounters journal-related exception on launch

Something has changed, measure now launches OK. The exception still appears but I think measure is working otherwise.

comment:3 Changed 6 years ago by morgs

  • Action Needed changed from never set to diagnose
  • Cc morgs added
  • Milestone set to 8.2.0 (was Update.2)
  • Version set to Development build as of this date

The activity launches but still fails in its functionality. The main screen area is gray, and does not display the input signal.

I get the same errors in the logs.

Joyride 2200.

comment:4 Changed 6 years ago by cjb

  • Keywords blocks?:8.2.0 added
  • Priority changed from normal to blocker

comment:5 Changed 6 years ago by gregorio

  • Keywords blocks-:8.2.0 added; blocks?:8.2.0 removed

Hi Arjun,

Measure is one of our most important activities. However, I can't block the release for this.

So I really want to get it fixed and support in 8.2.0 but if you miss the ship date we will have to go without it.

I think you have a week or two but the sooner its fixed the better. Let me know if you need any information or help to get this resolved.

Thanks,

Greg S

comment:6 Changed 6 years ago by gregorio

  • Cc gregorio arjs added

comment:7 Changed 6 years ago by dsd

I have almost fixed this...

comment:8 Changed 6 years ago by dsd

  • Blocked By 7856 added
  • Summary changed from Measure encounters journal-related exception on launch to Measure broken in joyride

Problems are:

  • Porting to numpy needed (trivially easy)
  • notify::active behaviour change in #7856

comment:9 Changed 6 years ago by morgs

On Wed, Jul 30, 2008 at 06:08, C. Scott Ananian <cscott@…> wrote:

Note that just replacing:

import Numeric

with:

import numpy.oldnumeric as Numeric

may be sufficient to fix these activities. If more invasive changes
are required, numpy.oldnumeric.alter_code1 contains routines to
automatically convert most Numeric code to run under numpy.

--scott

comment:10 follow-up: Changed 6 years ago by arjs

I just got a chance to look at the tickets and catch up with Measure related issues.
I will fix this within a day or so. Thanks for the testing.

Also, isn't this ticket a duplicate of #7771 ?

comment:11 in reply to: ↑ 10 Changed 6 years ago by morgs

Replying to arjs:

I just got a chance to look at the tickets and catch up with Measure related issues.
I will fix this within a day or so. Thanks for the testing.

Also, isn't this ticket a duplicate of #7771 ?

Yes, although this one is blocked on #7856 which is relevant to Measure. You could merge that into #7771 and close this...

comment:12 Changed 6 years ago by arjs

I have fixed Measure issue relating to not using Numeric and porting to numpy. (#7771)
However need confirmation that #7856 is a Measure issue rather than a Sugar issue to fix it. Thanks.

comment:13 Changed 6 years ago by arjs

  • Cc tomeu added

Tomeu: could you please see my last comment relating to #7856 and let me know ? Thanks.

comment:14 Changed 6 years ago by thomaswamm

  • Action Needed changed from diagnose to review

Measure-18 in build 8.2-757 starts with a grey screen (because of #7856). Easy work-around is to switch to Journal then back to Measure, then it works. Alt-tab is good.

comment:15 Changed 4 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed

Should be OK in v30

Note: See TracTickets for help on using tickets.