Opened 6 years ago

Closed 6 years ago

#7843 closed defect (duplicate)

Read keep error on exit

Reported by: dsd Owned by: sayamindu
Priority: high Milestone: 8.2.0 (was Update.2)
Component: read-activity Version: not specified
Keywords: Read-48:- Cc:
Blocked By: Blocking:
Deployments affected: Action Needed: diagnose
Verified: no

Description

After opening a PDF in Read, when you try and stop the activity it gives you a "Keep error" and asks if you want to stop it anyway. Joyride 2260, Read v48.

Change History (3)

comment:1 Changed 6 years ago by marco

  • Action Needed changed from never set to diagnose
  • Priority changed from normal to high

comment:2 Changed 6 years ago by skierpage

Happens in Read 49 on joyride-2273 as well.
After exporting SUGAR_LOG_LEVEL=debug in ~/.session, starting Read a PDF, then clicking Stop, my Read log had the following, possibly relevant lines:

1218273209.851749 DEBUG root: Written object b630542d-0bcc-4aea-a99d-37f67391961f to the datastore.
1218273209.970081 DEBUG root: Activity.save_error_cb
1218273210.056880 DEBUG root: Error saving activity object to datastore:
org.freedesktop.DBus.Python.IOError: Traceback (most recent call last):

File "/usr/lib/python2.5/site-packages/dbus/service.py", line 696, in _message_cb

retval = candidate_method(self, *args, keywords)

File "/usr/lib/python2.5/site-packages/olpc/datastore/datastore.py", line 457, in update

completion=lambda *args: self._update_completion_cb(async_cb, async_err_cb, content, *args))

File "/usr/lib/python2.5/site-packages/olpc/datastore/backingstore.py", line 645, in update_async

filelike = open(filelike, "r")

IOError: [Errno 2] No such file or directory: dbus.String(u'/home/olpc/isolation/1/uid_to_home_dir/10000/instance/1218273209')

comment:3 Changed 6 years ago by morgs

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #6488

Note: See TracTickets for help on using tickets.