Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#7852 closed defect (fixed)

Speak-5 times out when launching on joyride-2258 (No module named Numeric)

Reported by: garycmartin Owned by: morgs
Priority: high Milestone: 8.2.0 (was Update.2)
Component: speak-activity Version: Development build as of this date
Keywords: 8.2.0:? Measure Speak Cc: j@…, Rmyers
Blocked By: Blocking:
Deployments affected: Action Needed: test in build
Verified: no

Description

Clicking to launch Speak from the home ring displays the launching splash screen correctly, but then sits there for a long time before timing out. I've attached Speak logs, but just looks like the Numeric related package change has caused the breakage.

Attachments (2)

vu.lux.olpc.Speak-1.log (13.8 KB) - added by garycmartin 6 years ago.
speak.diff (381 bytes) - added by morgs 6 years ago.
Patch which fixes this on joyride-2301

Download all attachments as: .zip

Change History (15)

Changed 6 years ago by garycmartin

comment:1 Changed 6 years ago by mantaraya36

The measure activity exhibits the same problem.

comment:2 Changed 6 years ago by kimquirk

  • Keywords 8.2.0:? added
  • Owner changed from mstone to morgs

Morgs - can you find an owner to help look into this?

comment:3 Changed 6 years ago by garycmartin

Speak activity is by Joshua Minor (User:Jminor) email is j at lux.vu. I've sent a quick ping email (cc:ed morgs).

comment:4 Changed 6 years ago by thomaswamm

  • Action Needed changed from never set to diagnose
  • Keywords Measure Speak added
  • Priority changed from normal to high

Measure activity also times out when launching in joyride-2301.

ImportError: No module named Numeric

comment:5 follow-up: Changed 6 years ago by thomaswamm

This is probably a duplicate of http://dev.laptop.org/ticket/7771.

comment:6 in reply to: ↑ 5 Changed 6 years ago by morgs

Replying to thomaswamm:

This is probably a duplicate of http://dev.laptop.org/ticket/7771.

That ticket is for Measure, this one is for Speak...

comment:7 Changed 6 years ago by morgs

On Wed, Jul 30, 2008 at 06:08, C. Scott Ananian <cscott@…> wrote:

Note that just replacing:

import Numeric

with:

import numpy.oldnumeric as Numeric

may be sufficient to fix these activities. If more invasive changes
are required, numpy.oldnumeric.alter_code1 contains routines to
automatically convert most Numeric code to run under numpy.

--scott

Changed 6 years ago by morgs

Patch which fixes this on joyride-2301

comment:8 Changed 6 years ago by morgs

I'll get Joshua to apply this patch or I'll push it if I get no response.

comment:9 Changed 6 years ago by jminor

  • Cc j@… added

Lets add a try/catch to fall back to the old modules so that the new version of Speak will work on new and old releases of Sugar.

comment:10 Changed 6 years ago by Rmyers

  • Cc Rmyers added

comment:11 Changed 6 years ago by morgs

  • Action Needed changed from diagnose to test in build

I've released Speak-7 with the fix, and tested on build 708 and joyride 2301.

Get it from http://dev.laptop.org/~morgan/bundles/Speak-7.xo

garycmartin, you can close this ticket if it works for you...

comment:12 Changed 6 years ago by garycmartin

  • Resolution set to fixed
  • Status changed from new to closed

Also tested on an XO B4 in joyride-2301 here. Control panel updated it correctly, fav stars and all. Speech correctly runs, displays the different mouth styles, and sound works. Fixed.

comment:13 Changed 6 years ago by cjl

  • Component changed from other-activity to speak-activity
Note: See TracTickets for help on using tickets.