Opened 6 years ago

Last modified 6 years ago

#7895 reopened defect

Journal does not always show mounted USB drives

Reported by: martin.langhoff Owned by: tomeu
Priority: normal Milestone: 8.2.0 (was Update.2)
Component: journal-activity Version: not specified
Keywords: joyride-2270 blocks-:8.2.0 relnote Cc: gregorio
Blocked By: Blocking:
Deployments affected: Action Needed: reproduce
Verified: no

Description

Trying with various usb disks (vfat partitioned), all of them mount correctly -- dmesg reports them as mounted and accessing /media/<label> works, but some of them do not turn up in the Journal.

Attachments (1)

logs.SHC84200A67.2008-11-05.20-30-13.tar.bz2 (719.3 KB) - added by frances 6 years ago.
log of journal not recognizing the usb stick

Download all attachments as: .zip

Change History (17)

comment:1 Changed 6 years ago by martin.langhoff

Confirmed on joyride-2301 -

  • Journal logs don't show anything interesting
  • umount on the cli indicates the mountpoint is in use - probably Journal has something open in there - right now we don't have lsof or connectivity on the XO to test

This is probably related to #7993

comment:2 Changed 6 years ago by tomeu

  • Action Needed changed from never set to diagnose
  • Component changed from not assigned to journal-activity
  • Owner set to tomeu

Martin, can you attach debug logs anyway for the journal and the datastore? Also, can you check how many files are in the drive?

comment:3 Changed 6 years ago by cjb

  • Keywords blocks?:8.2.0 added

We talked about this in triage, it might be a blocker so proposing it as such.

comment:4 Changed 6 years ago by gregorio

  • Keywords blocks:8.2.0 added; blocks?:8.2.0 removed

comment:5 Changed 6 years ago by marco

  • Action Needed changed from diagnose to reproduce

We need logs or a way to reproduce to be able to do something about this one.

comment:6 Changed 6 years ago by tomeu

Logs would tell for sure, but in the meantime I'll say that removing the .olpc.store dir from the removable device will serve as a workaround.

comment:7 Changed 6 years ago by marco

Without logs or a way to reproduce in two weeks, I think this should be punted from blockers.

comment:8 Changed 6 years ago by martin.langhoff

Sorry. We did file a related one with good bugs & diagnosis:

#8099 ext3 formatted usb mounted but not visible in journal

Some more info in case it hels... one way I've repro'd this problem on vfat is:

  • on an 8.2-759 with content in the journal
  • plug vfat-formatted disk
  • from a terminal, cp -pr .sugar/default/datastore /media/<LABEL>/
  • unmount the disk from the journal
  • unplug
  • replug
  • ...

comment:9 Changed 6 years ago by marco

  • Resolution set to duplicate
  • Status changed from new to closed

comment:10 Changed 6 years ago by martin.langhoff

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Hi Marco this is not a duplicate of #8099 - there are 2 distinct bugs

  • this bug on with vfat - Journal goes la-la if there's a ton of files, or if there's something that looks like the journal data storage itself. Steps to repro posted yesterday.
  • #8099 - on ext3 - similar symptoms, different root cause

reopening tentatively... btw, if you meant dupe of a _different_ bug... which one? :-)

comment:11 Changed 6 years ago by marco

Gah, sorry I should read more carefully... I'll see if I can repro with your steps tomorrow. If you reproduce it again, logs would be very useful.

comment:12 Changed 6 years ago by marco

I tried hard but I cannot reproduce it.

Do you see the UI blocking for a bit when you click on the Unmount in the journal? Do you wait that the UI unblock and the bar at the bottom disappears? Unmounting while it's still syncing (the UI is blocked) is the only way I'm able to break it.

comment:13 Changed 6 years ago by marco

s/Unmounting when it's still syncing/Unplugging when it's still syncing

comment:14 Changed 6 years ago by mstone

  • Cc gregorio added
  • Keywords blocks-:8.2.0 relnote added; blocks:8.2.0 removed

We're downgrading this; there's more important stuff to work on.

comment:15 follow-up: Changed 6 years ago by frances

While smoke testing the lastest firmware q2e21, the new touchpad XO with build 767 wouldn't recognize the USB stick from the Journal. Same issue where in the console I can list the media device, but back in Journal no indication that there is a stick.

Logs attached.

Changed 6 years ago by frances

log of journal not recognizing the usb stick

comment:16 in reply to: ↑ 15 Changed 6 years ago by frances

Replying to frances:

While smoke testing the lastest firmware q2e21, the new touchpad XO with build 767 wouldn't recognize the USB stick from the Journal. Same issue where in the console I can list the media device, but back in Journal no indication that there is a stick.

Logs attached.

It may have been an issue with the USB key itself. The same XOs are responding to a new usb.

Note: See TracTickets for help on using tickets.